summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/ChangeLog9
-rw-r--r--net-misc/wget/Manifest2
-rw-r--r--net-misc/wget/files/digest-wget-1.102
-rw-r--r--net-misc/wget/wget-1.10.ebuild58
4 files changed, 70 insertions, 1 deletions
diff --git a/net-misc/wget/ChangeLog b/net-misc/wget/ChangeLog
index df53526b419f..b1a237921dea 100644
--- a/net-misc/wget/ChangeLog
+++ b/net-misc/wget/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/wget
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.69 2005/07/18 18:16:00 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.70 2005/07/18 19:33:05 seemant Exp $
+
+*wget-1.10 (18 Jul 2005)
+
+ 18 Jul 2005; Seemant Kulleen <seemant@gentoo.org> +wget-1.10.ebuild:
+ version bump thanks to Tijs Zwinkels <gentoobugs@tumblecow.net> for
+ notifying me in bug #96716, and to: emanuele.giaquinta@gmail.com for porting
+ the patchset over in the same bug
18 Jul 2005; Seemant Kulleen <seemant@gentoo.org> wget-1.9.1-r5.ebuild:
adjust patches: debian CAN fix and Mandrake largefile to compile with
diff --git a/net-misc/wget/Manifest b/net-misc/wget/Manifest
index 234c2e50dffc..da8f7ee40e89 100644
--- a/net-misc/wget/Manifest
+++ b/net-misc/wget/Manifest
@@ -2,5 +2,7 @@ MD5 d8da3021a3e635af9c4511b2a55b5633 metadata.xml 343
MD5 a0a0a49fd392c3a858b70242aa3f7268 wget-1.9.1-r3.ebuild 1561
MD5 fe2370f8eeca284cc848ce0b4c4c9ca4 ChangeLog 11510
MD5 537d722290d260b58444b9289569d23f wget-1.9.1-r5.ebuild 1691
+MD5 e6abb18e950356fd898dd61ecb5fd872 wget-1.10.ebuild 1613
MD5 94ce8e0557c28ef33d5814ab3dd34980 files/digest-wget-1.9.1-r3 135
MD5 9da83719265c58f22ba93bcb2e8d299f files/digest-wget-1.9.1-r5 136
+MD5 795bb7ec27bc4b404e90d058f00aff00 files/digest-wget-1.10 133
diff --git a/net-misc/wget/files/digest-wget-1.10 b/net-misc/wget/files/digest-wget-1.10
new file mode 100644
index 000000000000..99ffedbd1670
--- /dev/null
+++ b/net-misc/wget/files/digest-wget-1.10
@@ -0,0 +1,2 @@
+MD5 caddc199d2cb31969e32b19fd365b0c5 wget-1.10.tar.gz 1593119
+MD5 189554bc6fe08e9a8c7270107dbec304 wget-1.10-gentoo-0.1.tar.bz2 3398
diff --git a/net-misc/wget/wget-1.10.ebuild b/net-misc/wget/wget-1.10.ebuild
new file mode 100644
index 000000000000..2f66243fab0a
--- /dev/null
+++ b/net-misc/wget/wget-1.10.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.10.ebuild,v 1.1 2005/07/18 19:33:05 seemant Exp $
+
+inherit eutils flag-o-matic
+
+PATCHVER=0.1
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="http://wget.sunsite.dk/"
+SRC_URI="http://dev.gentoo.org/~seemant/distfiles/${P}.tar.gz
+ mirror://gnu/wget/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo-${PATCHVER}.tar.bz2
+ http://dev.gentoo.org/~seemant/distfiles/${P}-gentoo-${PATCHVER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ~ppc-macos ppc64 s390 sh sparc x86"
+IUSE="build debug ipv6 nls socks5 ssl static"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ socks5? ( net-proxy/dante )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-devel/autoconf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ local PATCHDIR=${WORKDIR}/patches
+ EPATCH_SUFFIX="patch"
+ EPATCH_MULTI_MSG="Applying Gentoo patches ..." epatch "${PATCHDIR}"/gentoo
+ EPATCH_MULTI_MSG="Applying Mandrake patches ..." epatch "${PATCHDIR}"/mandrake
+ autoconf || die "autoconf failed"
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf \
+ --sysconfdir=/etc/wget \
+ $(use_with ssl) $(use_enable ssl opie) $(use_enable ssl digest) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_with socks5 socks) \
+ || die
+ emake || die
+}
+
+src_install() {
+ if use build ; then
+ dobin "${S}"/src/wget || die "dobin"
+ return 0
+ fi
+
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog MACHINES MAILING-LIST NEWS README TODO
+ dodoc doc/sample.wgetrc
+}