summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/zaptel/files/zaptel-1.2.10-gentoo.diff')
-rw-r--r--net-misc/zaptel/files/zaptel-1.2.10-gentoo.diff104
1 files changed, 104 insertions, 0 deletions
diff --git a/net-misc/zaptel/files/zaptel-1.2.10-gentoo.diff b/net-misc/zaptel/files/zaptel-1.2.10-gentoo.diff
new file mode 100644
index 000000000000..ab4b77e3b440
--- /dev/null
+++ b/net-misc/zaptel/files/zaptel-1.2.10-gentoo.diff
@@ -0,0 +1,104 @@
+diff -Nura zaptel-1.2.10/build_tools/genmodconf zaptel-1.2.10.gentoo/build_tools/genmodconf
+--- zaptel-1.2.10/build_tools/genmodconf 2006-05-23 14:51:00.000000000 -0300
++++ zaptel-1.2.10.gentoo/build_tools/genmodconf 2006-11-07 16:50:50.334340709 -0300
+@@ -79,20 +79,6 @@
+
+ echo Building ${target}...
+
+-if [ "${1}" == "linux24" ]; then
+- for mod in ${3}; do
+- if ! grep -q "post-install ${mod} " ${target}; then
+- echo "post-install ${mod} /sbin/ztcfg" >> ${target}
+- fi
+- done
+-elif [ "${1}" == "linux26" ]; then
+- for mod in ${3}; do
+- if ! grep -q "install ${mod} " ${target}; then
+- echo "install ${mod} /sbin/modprobe --ignore-install ${mod} ${cmdopts} && /sbin/ztcfg" >> ${target}
+- fi
+- done
+-fi
+-
+ if ! grep -q "alias wcfxs" ${target}; then
+ echo "alias wcfxs wctdm" >> ${target};
+ fi;
+diff -Nura zaptel-1.2.10/build_tools/genudevrules zaptel-1.2.10.gentoo/build_tools/genudevrules
+--- zaptel-1.2.10/build_tools/genudevrules 2006-05-17 13:49:46.000000000 -0300
++++ zaptel-1.2.10.gentoo/build_tools/genudevrules 2006-11-07 16:50:50.335340457 -0300
+@@ -22,9 +22,9 @@
+
+ cat <<EOF
+ # zaptel devices with ownership/permissions for running as non-root
+-KERNEL${match}"zapctl", NAME="zap/ctl", OWNER="asterisk", GROUP="asterisk", MODE="0660"
+-KERNEL${match}"zaptimer", NAME="zap/timer", OWNER="asterisk", GROUP="asterisk", MODE="0660"
+-KERNEL${match}"zapchannel", NAME="zap/channel", OWNER="asterisk", GROUP="asterisk", MODE="0660"
+-KERNEL${match}"zappseudo", NAME="zap/pseudo", OWNER="asterisk", GROUP="asterisk", MODE="0660"
+-KERNEL${match}"zap[0-9]*", NAME="zap/%n", OWNER="asterisk", GROUP="asterisk", MODE="0660"
++KERNEL${match}"zapctl", NAME="zap/ctl", OWNER="root", GROUP="dialout", MODE="0660"
++KERNEL${match}"zaptimer", NAME="zap/timer", OWNER="root", GROUP="dialout", MODE="0660"
++KERNEL${match}"zapchannel", NAME="zap/channel", OWNER="root", GROUP="dialout", MODE="0660"
++KERNEL${match}"zappseudo", NAME="zap/pseudo", OWNER="root", GROUP="dialout", MODE="0660"
++KERNEL${match}"zap[0-9]*", NAME="zap/%n", OWNER="root", GROUP="dialout", MODE="0660"
+ EOF
+diff -Nura zaptel-1.2.10/Makefile zaptel-1.2.10.gentoo/Makefile
+--- zaptel-1.2.10/Makefile 2006-10-11 14:22:10.000000000 -0300
++++ zaptel-1.2.10.gentoo/Makefile 2006-11-07 16:52:46.910007121 -0300
+@@ -23,7 +23,7 @@
+ endif
+ KINCLUDES:=$(KSRC)/include
+
+-CFLAGS+=-I. -O4 -g -Wall -DBUILDING_TONEZONE #-DTONEZONE_DRIVER
++CFLAGS+=-I. -Iinclude -g -Wall -DBUILDING_TONEZONE #-DTONEZONE_DRIVER
+ CFLAGS_PPC:=$(shell if uname -m | grep -q ppc; then echo "-fsigned-char"; fi)
+ CFLAGS_X86-64:=$(shell if uname -m | grep -q x86_64; then echo "-m64"; fi)
+ CFLAGS+=$(CFLAGS_PPC) $(CFLAGS_X86-64)
+@@ -300,7 +300,8 @@
+ done
+ else # DYNFS
+ ifdef UDEVRULES
+- build_tools/genudevrules > $(INSTALL_PREFIX)/etc/udev/rules.d/zaptel.rules
++ build_tools/genudevrules > zaptel.rules
++ install -D -m 644 zaptel.rules $(INSTALL_PREFIX)/etc/udev/rules.d/10-zaptel.rules
+ else # !UDEVRULES
+ @echo "**** Dynamic filesystem detected -- not creating device nodes"
+ endif
+@@ -315,7 +316,7 @@
+ tar -zxf mISDNuser.tar.gz
+ $(MAKE) -C mISDNuser install
+
+-install: all devices firmware
++install: devices firmware
+ install -D -m 755 ztcfg $(INSTALL_PREFIX)/sbin/ztcfg
+ if [ -f sethdlc-new ]; then \
+ install -D -m 755 sethdlc-new $(INSTALL_PREFIX)/sbin/sethdlc; \
+@@ -338,24 +339,21 @@
+ fi; \
+ rm -f $(INSTALL_PREFIX)/lib/modules/$(KVERS)/misc/wcfxs.o
+ install -D -m 755 $(LIBTONEZONE_SO) $(INSTALL_PREFIX)/usr/lib/$(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER).$(LIBTONEZONE_SO_MINOR_VER)
+- [ `id -u` = 0 ] && /sbin/ldconfig || :
++ [ `id -u` = 0 ] && /sbin/ldconfig -n $(INSTALL_PREFIX)/usr/lib || :
+ rm -f $(INSTALL_PREFIX)/usr/lib/$(LIBTONEZONE_SO)
+ ln -sf $(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER).$(LIBTONEZONE_SO_MINOR_VER) \
+ $(INSTALL_PREFIX)/usr/lib/$(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER)
+ ln -sf $(LIBTONEZONE_SO).$(LIBTONEZONE_SO_MAJOR_VER).$(LIBTONEZONE_SO_MINOR_VER) \
+ $(INSTALL_PREFIX)/usr/lib/$(LIBTONEZONE_SO)
+- if [ -x /usr/sbin/sestatus ] && (/usr/sbin/sestatus | grep "SELinux status:" | grep -q "enabled") ; then restorecon -v $(INSTALL_PREFIX)/usr/lib/$(LIBTONEZONE_SO); fi
+ install -D -m 644 zaptel.h $(INSTALL_PREFIX)/usr/include/linux/zaptel.h
+ install -D -m 644 torisa.h $(INSTALL_PREFIX)/usr/include/linux/torisa.h
+ install -D -m 644 tonezone.h $(INSTALL_PREFIX)/usr/include/tonezone.h
+- install -m 644 doc/ztcfg.8 $(INSTALL_PREFIX)/usr/share/man/man8
+- install -m 644 doc/zttool.8 $(INSTALL_PREFIX)/usr/share/man/man8
+- [ `id -u` = 0 ] && /sbin/depmod -a $(KVERS) || :
++ install -d $(INSTALL_PREFIX)/usr/share/man/man8
++ install -m 644 doc/ztcfg.8 $(INSTALL_PREFIX)/usr/share/man/man8/
++ install -m 644 doc/zttool.8 $(INSTALL_PREFIX)/usr/share/man/man8/
+ [ -f $(CONFIG_FILE) ] || install -D -m 644 zaptel.conf.sample $(CONFIG_FILE)
+- build_tools/genmodconf $(BUILDVER) "$(ROOT_PREFIX)" "$(filter-out zaptel,$(MODULES))"
+- @if [ -d /etc/modutils ]; then \
+- /sbin/update-modules ; \
+- fi
++ install -d -m 755 $(INSTALL_PREFIX)/etc/modules.d
++ build_tools/genmodconf $(BUILDVER) "$(INSTALL_PREFIX)" "$(filter-out zaptel,$(MODULES))"
+
+ install-udev: devices
+