summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nds/ypbind/ypbind-1.17.2.ebuild')
-rw-r--r--net-nds/ypbind/ypbind-1.17.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-nds/ypbind/ypbind-1.17.2.ebuild b/net-nds/ypbind/ypbind-1.17.2.ebuild
new file mode 100644
index 000000000000..a37f7ac03065
--- /dev/null
+++ b/net-nds/ypbind/ypbind-1.17.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.17.2.ebuild,v 1.1 2004/02/24 18:02:45 tester Exp $
+
+IUSE="nls"
+
+MY_P=${PN}-mt-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Multithreaded NIS bind service (ypbind-mt)"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+
+DEPEND="net-nds/yp-tools net-nds/portmap"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+ econf ${myconf} || die
+ make || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog COPYING README THANKS TODO
+ insinto /etc ; doins etc/yp.conf
+ insinto /etc/conf.d ; newins ${FILESDIR}/ypbind.confd ypbind
+ exeinto /etc/init.d ; newexe ${FILESDIR}/ypbind.rc6 ypbind
+}
+
+pkg_postinst() {
+ einfo "To complete setup, you will need to edit /etc/conf.d/ypbind."
+ einfo "If you are using dhcpcd, be sure to add the -Y option to"
+ einfo "dhcpcd_eth0 (or eth1, etc.) to keep dhcpcd from clobbering"
+ einfo "/etc/yp.conf."
+}