summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/amule/amule-1.2.5.ebuild')
-rw-r--r--net-p2p/amule/amule-1.2.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-p2p/amule/amule-1.2.5.ebuild b/net-p2p/amule/amule-1.2.5.ebuild
new file mode 100644
index 000000000000..56ba1da9d4d7
--- /dev/null
+++ b/net-p2p/amule/amule-1.2.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-1.2.5.ebuild,v 1.1 2004/02/11 20:31:17 mholzer Exp $
+
+MY_P=${P/m/M}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="aNOTHER wxWindows based eMule P2P Client"
+HOMEPAGE="http://sourceforge.net/projects/amule"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="nls"
+
+DEPEND=">=x11-libs/wxGTK-2.4.1
+ >=net-ftp/curl-7.9.7
+ >=sys-libs/zlib-1.2.1"
+
+src_compile() {
+ econf `use_enable nls` || die
+ emake -j1 || die
+}
+
+src_install() {
+ einstall || die
+}