summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/amule/amule-2.2.0_pre20070422.ebuild')
-rw-r--r--net-p2p/amule/amule-2.2.0_pre20070422.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/net-p2p/amule/amule-2.2.0_pre20070422.ebuild b/net-p2p/amule/amule-2.2.0_pre20070422.ebuild
index dbca1e79f510..265a14c50478 100644
--- a/net-p2p/amule/amule-2.2.0_pre20070422.ebuild
+++ b/net-p2p/amule/amule-2.2.0_pre20070422.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.0_pre20070422.ebuild,v 1.3 2007/10/13 16:16:45 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.0_pre20070422.ebuild,v 1.4 2008/01/15 13:43:48 armin76 Exp $
inherit eutils flag-o-matic wxwidgets
@@ -14,7 +14,7 @@ SRC_URI="http://www.hirnriss.net/files/cvs/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="amuled debug gtk nls remote stats unicode"
+IUSE="daemon debug gtk nls remote stats unicode"
DEPEND="=x11-libs/wxGTK-2.6*
>=sys-libs/zlib-1.2.1
@@ -23,9 +23,9 @@ DEPEND="=x11-libs/wxGTK-2.6*
unicode? ( >=media-libs/gd-2.0.26 ) )"
pkg_setup() {
- if ! use gtk && ! use remote && ! use amuled; then
+ if ! use gtk && ! use remote && ! use daemon; then
eerror ""
- eerror "You have to specify at least one of gtk, remote or amuled"
+ eerror "You have to specify at least one of gtk, remote or daemon"
eerror "USE flag to build amule."
eerror ""
die "Invalid USE flag set"
@@ -43,7 +43,7 @@ pkg_setup() {
}
pkg_preinst() {
- if use amuled || use remote; then
+ if use daemon || use remote; then
enewgroup p2p
enewuser p2p -1 -1 /home/p2p p2p
fi
@@ -85,7 +85,7 @@ src_compile() {
--enable-amulecmd \
`use_enable debug` \
`use_enable !debug optimize` \
- `use_enable amuled amule-daemon` \
+ `use_enable daemon amule-daemon` \
`use_enable nls` \
`use_enable remote webserver` \
`use_enable stats cas` \
@@ -101,7 +101,7 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die
- if use amuled; then
+ if use daemon; then
newconfd "${FILESDIR}"/amuled.confd amuled
newinitd "${FILESDIR}"/amuled.initd amuled
fi