summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/gnunet/gnunet-0.6.1b.ebuild')
-rw-r--r--net-p2p/gnunet/gnunet-0.6.1b.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-p2p/gnunet/gnunet-0.6.1b.ebuild b/net-p2p/gnunet/gnunet-0.6.1b.ebuild
new file mode 100644
index 000000000000..c0a33a6f68ec
--- /dev/null
+++ b/net-p2p/gnunet/gnunet-0.6.1b.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.6.1b.ebuild,v 1.1 2004/02/27 02:36:38 eradicator Exp $
+
+inherit libtool
+
+S="${WORKDIR}/GNUnet-${PV}"
+DESCRIPTION="GNUnet is an anonymous, distributed, reputation based network."
+HOMEPAGE="http://www.ovmj.org/GNUnet/"
+SRC_URI="http://www.ovmj.org/GNUnet/download/GNUnet-${PV}.tar.bz2"
+
+IUSE="ipv6"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=dev-libs/openssl-0.9.6d
+ >=sys-libs/gdbm-1.8.0
+ =dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ >=dev-libs/libextractor-0.2.6"
+
+src_compile() {
+ elibtoolize
+ econf `use_enable ipv6` || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog PLATFORMS README UPDATING
+ insinto /etc
+ newins contrib/gnunet.conf.root gnunet.conf
+ docinto contrib
+ dodoc contrib/*
+}
+
+pkg_postinst() {
+ use ipv6 && ewarn "ipv6 support is -very- experimental and prone to bug"
+ einfo
+ einfo "now copy an appropriate config file from"
+ einfo "/usr/share/doc/${P}/contrib"
+ einfo "to ~/.gnunet/gnunet.conf"
+ einfo
+}