summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/tribler/tribler-5.5.23.ebuild')
-rw-r--r--net-p2p/tribler/tribler-5.5.23.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/net-p2p/tribler/tribler-5.5.23.ebuild b/net-p2p/tribler/tribler-5.5.23.ebuild
deleted file mode 100644
index 869bdb08c472..000000000000
--- a/net-p2p/tribler/tribler-5.5.23.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/tribler/tribler-5.5.23.ebuild,v 1.1 2012/03/16 10:55:40 blueness Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2:2.5"
-
-inherit eutils python
-
-MY_PV="${PN}_${PV}-1ubuntu1_all"
-
-DESCRIPTION="Bittorrent client that does not require a website to discover content"
-HOMEPAGE="http://www.tribler.org/"
-SRC_URI="http://dl.tribler.org/${MY_PV}.deb"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="vlc"
-
-RDEPEND=">=dev-lang/python-2.5[sqlite]
- >=dev-python/m2crypto-0.16
- >=dev-python/wxpython-2.8
- >=dev-python/apsw-3.6
- >=dev-libs/openssl-0.9.8
- vlc? ( >=media-video/vlc-1.0.1 )"
-
-# Skipping for now:
-# xulrunner-sdk >= 1.9.1.5 < 1.9.2 (optional, to run SwarmTransport)
-# 7-Zip >= 4.6.5 (optional, to build SwarmTransport)
-
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
- unpack ./data.tar.gz
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-fix-global-declarations.patch"
- epatch "${FILESDIR}/${PN}-log2homedir.patch"
-
- python_convert_shebangs -r 2 .
-}
-
-src_compile() { :; }
-
-src_install() {
- #Rename the doc dir properly
- mv usr/share/doc/${PN} usr/share/doc/${P}
-
- #Move the readme to the doc dir
- mv usr/share/${PN}/Tribler/readme.txt usr/share/doc/${P}
-
- #Remove the licenses scattered throughout
- rm usr/share/doc/${P}/copyright
- rm usr/share/${PN}/Tribler/*.txt
- rm usr/share/${PN}/Tribler/Core/DecentralizedTracking/pymdht/{LGPL-2.1.txt,LICENSE.txt}
-
- #Copy the rest over
- cp -pPR usr/ "${ED}"/
-}
-
-pkg_postinst() {
- python_mod_optimize "${ROOT}"usr/share/${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup "${ROOT}"usr/share/${PN}
-}