summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/gtklp/gtklp-1.2.1.ebuild')
-rw-r--r--net-print/gtklp/gtklp-1.2.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-print/gtklp/gtklp-1.2.1.ebuild b/net-print/gtklp/gtklp-1.2.1.ebuild
new file mode 100644
index 000000000000..46d72e50ff65
--- /dev/null
+++ b/net-print/gtklp/gtklp-1.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/gtklp-1.2.1.ebuild,v 1.1 2006/04/02 21:58:53 genstef Exp $
+
+DESCRIPTION="A GUI for cupsd"
+SRC_URI="mirror://sourceforge/gtklp/${P}.src.tar.gz"
+HOMEPAGE="http://gtklp.sourceforge.net"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+LICENSE="GPL-2"
+IUSE="nls ssl"
+
+DEPEND=">=x11-libs/gtk+-2
+ >=net-print/cups-1.1.12
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable ssl) \
+ || die "configure failed"
+ emake || die "parallel make failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS BUGS ChangeLog NEWS README README.FAQ TODO USAGE
+
+ use nls || rm -rf "${D}"/usr/share/locale
+}