summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/hostap-driver/hostap-driver-0.4.0.ebuild')
-rw-r--r--net-wireless/hostap-driver/hostap-driver-0.4.0.ebuild98
1 files changed, 0 insertions, 98 deletions
diff --git a/net-wireless/hostap-driver/hostap-driver-0.4.0.ebuild b/net-wireless/hostap-driver/hostap-driver-0.4.0.ebuild
deleted file mode 100644
index 2165cb6882f9..000000000000
--- a/net-wireless/hostap-driver/hostap-driver-0.4.0.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-driver/hostap-driver-0.4.0.ebuild,v 1.1 2005/04/27 09:57:27 brix Exp $
-
-inherit toolchain-funcs eutils linux-mod
-
-DESCRIPTION="HostAP wireless drivers"
-HOMEPAGE="http://hostap.epitest.fi"
-SRC_URI="${SRC_URI} http://hostap.epitest.fi/releases/${P}.tar.gz"
-LICENSE="GPL-2"
-
-KEYWORDS="~x86 ~ppc"
-IUSE="pcmcia"
-SLOT="0"
-
-RDEPEND=">=net-wireless/wireless-tools-25"
-
-BUILD_PARAMS="KERNEL_PATH=${KV_DIR}"
-BUILD_TARGETS="all"
-MODULESD_HOSTAP_DOCS="README"
-
-CONFIG_CHECK="NET_RADIO"
-NET_RADIO_ERROR="${P} requires support for Wireless LAN drivers (non-hamradio) & Wireless Extensions (CONFIG_NET_RADIO)."
-
-pkg_setup() {
- MODULE_NAMES="hostap(net::${S}/driver/modules)
- hostap_pci(net::${S}/driver/modules)
- hostap_plx(net::${S}/driver/modules)
- hostap_crypt_wep(net::${S}/driver/modules)
- hostap_crypt_ccmp(net::${S}/driver/modules)
- hostap_crypt_tkip(net::${S}/driver/modules)"
-
- if use pcmcia; then
- MODULE_NAMES="${MODULE_NAMES} hostap_cs(net::${S}/driver/modules)"
- fi
-
- linux-mod_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- epatch ${FILESDIR}/${P}-firmware.patch
-
- # set compiler
- sed -i "s:gcc:$(tc-getCC):" ${S}/Makefile
-
- # unpack the pcmcia-cs sources if needed
- pcmcia_src_unpack
-
- # fix for new coreutils (#31801)
- sed -i "s:tail -1:tail -n 1:" ${S}/Makefile
-
- # set correct pcmcia path (PCMCIA_VERSION gets set from pcmcia_src_unpack)
- if [ -n "${PCMCIA_VERSION}" ]; then
- sed -i "s:^\(PCMCIA_PATH\)=:\1=${PCMCIA_SOURCE_DIR}:" ${S}/Makefile
- fi
-
- convert_to_m ${S}/Makefile
-}
-
-src_compile() {
- linux-mod_src_compile
-}
-
-src_install() {
- if use pcmcia; then
- insinto /etc/pcmcia
- doins driver/etc/hostap_cs.conf
- fi
-
- dodoc ChangeLog
-
- linux-mod_src_install
-}
-
-pkg_postinst() {
- if [ -e /etc/pcmcia/prism2.conf ]
- then
- einfo ""
- einfo "You may need to edit or remove /etc/pcmcia/prism2.conf"
- einfo "This is usually a result of conflicts with the"
- einfo "net-wireless/linux-wlan-ng drivers."
- einfo ""
- fi
-
- ewarn ""
- ewarn "Please note that this installation of HostAP contains support"
- ewarn "for downloading binary firmware images into the non-volatile"
- ewarn "(permanent) flash memory of wireless LAN cards."
- ewarn ""
- ewarn "Albeit being a great feature, this can lead to A DEAD CARD"
- ewarn "when inappropriately used (e.g. wrong firmware)."
- ewarn ""
-
- linux-mod_pkg_postinst
-}