summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/acx/acx-0.3.35_p20060521.ebuild50
-rw-r--r--net-wireless/acx/acx-0.3.35_p20070101.ebuild50
-rw-r--r--net-wireless/acx/files/acx-0.3.35_p20060521-2.6.18.patch14
-rw-r--r--net-wireless/acx/files/acx-0.3.35_p20060521-2.6.19.patch100
-rw-r--r--net-wireless/acx/files/acx-0.3.35_p20070101-2.6.22.patch29
-rw-r--r--net-wireless/acx/files/acx-0.3.37_p20080112.patch38
6 files changed, 0 insertions, 281 deletions
diff --git a/net-wireless/acx/acx-0.3.35_p20060521.ebuild b/net-wireless/acx/acx-0.3.35_p20060521.ebuild
deleted file mode 100644
index 07fdd43263bf..000000000000
--- a/net-wireless/acx/acx-0.3.35_p20060521.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/acx-0.3.35_p20060521.ebuild,v 1.5 2007/07/27 06:21:23 genstef Exp $
-
-inherit linux-mod
-
-DESCRIPTION="Driver for the ACX100 and ACX111 wireless chipset (CardBus, PCI, USB)"
-
-HOMEPAGE="http://acx100.sourceforge.net/"
-SRC_URI="http://acx100.erley.org/acx-20060521.tar.bz2"
-
-LICENSE="GPL-2 as-is"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc x86"
-
-IUSE="debug"
-
-RDEPEND="net-wireless/wireless-tools
- net-wireless/acx-firmware"
-
-S=${WORKDIR}
-
-MODULE_NAMES="acx(net:${S})"
-CONFIG_CHECK="WIRELESS_EXT FW_LOADER"
-BUILD_TARGETS="modules"
-
-pkg_setup() {
- linux-mod_pkg_setup
- BUILD_PARAMS="-C ${KV_DIR} SUBDIRS=${S}"
-}
-
-src_unpack() {
- unpack ${A}
- chmod ug+w . -R
-
- # The default acx_config.h has some rather over-zealous debug output.
- if ! use debug; then
- sed -i '/^#define ACX_DEBUG/s/2/0/' acx_config.h || die "Failed to disable debug support"
- fi
-
- # fix 2.6.18 compilation
- epatch ${FILESDIR}/${P}-2.6.18.patch
- epatch ${FILESDIR}/${P}-2.6.19.patch
-}
-
-src_install() {
- linux-mod_src_install
-
- dodoc README
-}
diff --git a/net-wireless/acx/acx-0.3.35_p20070101.ebuild b/net-wireless/acx/acx-0.3.35_p20070101.ebuild
deleted file mode 100644
index 948ed1222267..000000000000
--- a/net-wireless/acx/acx-0.3.35_p20070101.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/acx-0.3.35_p20070101.ebuild,v 1.4 2007/07/27 20:17:37 mr_bones_ Exp $
-
-inherit linux-mod
-
-PATCHLEVEL=${PV##*_p}
-
-DESCRIPTION="Driver for the ACX100 and ACX111 wireless chipset (CardBus, PCI, USB)"
-HOMEPAGE="http://acx100.sourceforge.net/"
-SRC_URI="http://lisas.de/~andi/acx100/${PN}-${PATCHLEVEL}.tar.bz2"
-
-LICENSE="GPL-2 as-is"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-IUSE="debug"
-
-RDEPEND="net-wireless/wireless-tools
- net-wireless/acx-firmware"
-
-S=${WORKDIR}/${PN}-${PATCHLEVEL}
-
-MODULE_NAMES="acx(net:${S})"
-CONFIG_CHECK="WIRELESS_EXT FW_LOADER"
-BUILD_TARGETS="modules"
-
-pkg_setup() {
- linux-mod_pkg_setup
- BUILD_PARAMS="-C ${KV_DIR} SUBDIRS=${S}"
-}
-
-src_unpack() {
- unpack ${A}
- chmod ug+w . -R
-
- # The default acx_config.h has some rather over-zealous debug output.
- cd $S
- if ! use debug; then
- sed -i '/^#define ACX_DEBUG/s/2/0/' acx_config.h || die "Failed to disable debug support"
- fi
- kernel_is ge 2 6 22 && epatch ${FILESDIR}/${P}-2.6.22.patch
-
-}
-
-src_install() {
- linux-mod_src_install
-
- dodoc README
-}
diff --git a/net-wireless/acx/files/acx-0.3.35_p20060521-2.6.18.patch b/net-wireless/acx/files/acx-0.3.35_p20060521-2.6.18.patch
deleted file mode 100644
index 922e74d26ff6..000000000000
--- a/net-wireless/acx/files/acx-0.3.35_p20060521-2.6.18.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: work/pci.c
-===================================================================
---- work.orig/pci.c
-+++ work/pci.c
-@@ -51,6 +51,9 @@
- #include <linux/pm.h>
- #include <linux/vmalloc.h>
- #include <linux/dma-mapping.h>
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,17)
-+#include <linux/utsrelease.h>
-+#endif
-
- #include "acx.h"
-
diff --git a/net-wireless/acx/files/acx-0.3.35_p20060521-2.6.19.patch b/net-wireless/acx/files/acx-0.3.35_p20060521-2.6.19.patch
deleted file mode 100644
index c8ff8e440ed2..000000000000
--- a/net-wireless/acx/files/acx-0.3.35_p20060521-2.6.19.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-diff -ur acx.orig/common.c acx/common.c
---- acx.orig/common.c 2006-05-20 19:27:58.000000000 +0100
-+++ acx/common.c 2006-12-20 02:12:54.000000000 +0000
-@@ -30,8 +30,11 @@
- ** ---------------------------------------------------------------------
- */
-
--#include <linux/config.h>
- #include <linux/version.h>
-+#if LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,18)
-+#include <linux/config.h>
-+#endif
-+
- #include <linux/module.h>
- #include <linux/kernel.h>
- #include <linux/sched.h>
-Only in acx: .common.c.swp
-diff -ur acx.orig/conv.c acx/conv.c
---- acx.orig/conv.c 2006-05-20 19:27:57.000000000 +0100
-+++ acx/conv.c 2006-12-20 02:12:49.000000000 +0000
-@@ -30,8 +30,11 @@
- ** ---------------------------------------------------------------------
- */
-
--#include <linux/config.h>
- #include <linux/version.h>
-+#if LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,18)
-+#include <linux/config.h>
-+#endif
-+
- #include <linux/skbuff.h>
- #include <linux/if_arp.h>
- #include <linux/etherdevice.h>
-Only in acx: .conv.c.swp
-diff -ur acx.orig/ioctl.c acx/ioctl.c
---- acx.orig/ioctl.c 2006-05-20 19:27:59.000000000 +0100
-+++ acx/ioctl.c 2006-12-20 02:13:05.000000000 +0000
-@@ -30,8 +30,11 @@
- ** ---------------------------------------------------------------------
- */
-
--#include <linux/config.h>
- #include <linux/version.h>
-+#if LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,18)
-+#include <linux/config.h>
-+#endif
-+
- #include <linux/kernel.h>
- #include <linux/types.h>
- #include <asm/io.h>
-Only in acx: .ioctl.c.swp
-diff -ur acx.orig/pci.c acx/pci.c
---- acx.orig/pci.c 2006-05-20 20:11:13.000000000 +0100
-+++ acx/pci.c 2006-12-20 02:12:33.000000000 +0000
-@@ -31,8 +31,11 @@
- */
- #define ACX_PCI 1
-
--#include <linux/config.h>
- #include <linux/version.h>
-+#if LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,18)
-+#include <linux/config.h>
-+#endif
-+
- #include <linux/compiler.h> /* required for Lx 2.6.8 ?? */
- #include <linux/kernel.h>
- #include <linux/module.h>
-Only in acx: .pci.c.swp
-diff -ur acx.orig/usb.c acx/usb.c
---- acx.orig/usb.c 2006-05-20 19:27:57.000000000 +0100
-+++ acx/usb.c 2006-12-20 02:12:37.000000000 +0000
-@@ -45,7 +45,10 @@
- #define ACX_USB 1
-
- #include <linux/version.h>
-+#if LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,18)
- #include <linux/config.h>
-+#endif
-+
- #include <linux/types.h>
- #include <linux/module.h>
- #include <linux/moduleparam.h>
-Only in acx: .usb.c.swp
-diff -ur acx.orig/wlan.c acx/wlan.c
---- acx.orig/wlan.c 2006-05-20 19:27:59.000000000 +0100
-+++ acx/wlan.c 2006-12-20 02:12:59.000000000 +0000
-@@ -37,8 +37,11 @@
- ** http://www.linux-wlan.com
- */
-
--#include <linux/config.h>
- #include <linux/version.h>
-+#if LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,18)
-+#include <linux/config.h>
-+#endif
-+
- #include <linux/types.h>
- #include <linux/if_arp.h>
- #include <linux/wireless.h>
-Only in acx: .wlan.c.swp
diff --git a/net-wireless/acx/files/acx-0.3.35_p20070101-2.6.22.patch b/net-wireless/acx/files/acx-0.3.35_p20070101-2.6.22.patch
deleted file mode 100644
index 5db2a9c3859c..000000000000
--- a/net-wireless/acx/files/acx-0.3.35_p20070101-2.6.22.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- acx-20070101/pci.c.orig 2007-07-24 03:57:41.000000000 -0700
-+++ acx-20070101/pci.c 2007-07-24 03:59:20.000000000 -0700
-@@ -2104,7 +2104,11 @@
- /* TODO: pci_set_power_state(pdev, PCI_D0); ? */
-
- /* request shared IRQ handler */
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,21)
-+ if (request_irq(ndev->irq, acxpci_i_interrupt, IRQF_SHARED, ndev->name, ndev)) {
-+#else
- if (request_irq(ndev->irq, acxpci_i_interrupt, SA_SHIRQ, ndev->name, ndev)) {
-+#endif
- printk("%s: request_irq FAILED\n", ndev->name);
- result = -EAGAIN;
- goto done;
---- acx-20070101/common.c.orig 2007-07-24 03:59:40.000000000 -0700
-+++ acx-20070101/common.c 2007-07-24 04:01:23.000000000 -0700
-@@ -2753,8 +2753,11 @@
-
- skb->dev = adev->ndev;
- skb->dev->last_rx = jiffies;
--
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,22)
-+ skb_reset_mac_header(skb);
-+#else
- skb->mac.raw = skb->data;
-+#endif
- skb->ip_summed = CHECKSUM_NONE;
- skb->pkt_type = PACKET_OTHERHOST;
- skb->protocol = htons(ETH_P_80211_RAW);
diff --git a/net-wireless/acx/files/acx-0.3.37_p20080112.patch b/net-wireless/acx/files/acx-0.3.37_p20080112.patch
deleted file mode 100644
index ecfbd3c8a9e4..000000000000
--- a/net-wireless/acx/files/acx-0.3.37_p20080112.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- acx-20080112/pci.c.orig
-+++ acx-20080112/pci.c
-@@ -1632,8 +1632,10 @@
- acx_show_card_eeprom_id(adev);
- #endif /* NONESSENTIAL_FEATURES */
-
-+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
- #ifdef SET_MODULE_OWNER
-- SET_MODULE_OWNER(ndev);
-+ SET_MODULE_OWNER(ndev);
-+#endif
- #endif
- SET_NETDEV_DEV(ndev, &pdev->dev);
-
-@@ -2128,7 +2130,11 @@
- /* TODO: pci_set_power_state(pdev, PCI_D0); ? */
-
- /* request shared IRQ handler */
-+ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,21))
-+ if (request_irq(ndev->irq, acxpci_i_interrupt, IRQF_SHARED, ndev->name, ndev)) {
-+ #else
- if (request_irq(ndev->irq, acxpci_i_interrupt, SA_SHIRQ, ndev->name, ndev)) {
-+ #endif
- printk("%s: request_irq FAILED\n", ndev->name);
- result = -EAGAIN;
- goto done;
---- acx-20080112/usb.c.orig
-+++ acx-20080112/usb.c
-@@ -859,7 +859,9 @@
- ndev->watchdog_timeo = 4 * HZ;
- #endif
- ndev->change_mtu = &acx_e_change_mtu;
-+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
- SET_MODULE_OWNER(ndev);
-+#endif
-
- /* Setup private driver context */
-