summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/apache/apache-2.0.54-r31.ebuild')
-rw-r--r--net-www/apache/apache-2.0.54-r31.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-www/apache/apache-2.0.54-r31.ebuild b/net-www/apache/apache-2.0.54-r31.ebuild
index 9c6556011c3a..64e24646c5d8 100644
--- a/net-www/apache/apache-2.0.54-r31.ebuild
+++ b/net-www/apache/apache-2.0.54-r31.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.54-r31.ebuild,v 1.16 2005/10/07 18:11:47 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.54-r31.ebuild,v 1.17 2005/12/11 03:01:15 vericgar Exp $
inherit eutils gnuconfig multilib
@@ -264,6 +264,7 @@ src_install () {
mv usr/sbin/envvars* usr/$(get_libdir)/apache2/build
dodoc etc/apache2/*-std.conf
rm -f etc/apache2/*.conf
+ rm -f etc/apache2/mime.types
rm -rf var/run var/log
# we DEPEND on net-www/gentoo-webroot-default for sharing this by now
@@ -306,8 +307,11 @@ src_install () {
}
pkg_postinst() {
+ # setup apache user and group
+ enewgroup apache 81
+ enewuser apache 81 -1 /var/www apache
- # Automatically generate test ceritificates if ssl USE flag is beeing set
+ # Automatically generate test ceritificates if ssl USE flag is being set
if useq ssl -a !-e ${ROOT}/etc/apache2/ssl/server.crt; then
cd ${ROOT}/etc/apache2/ssl
einfo