summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild')
-rw-r--r--net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild b/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild
deleted file mode 100644
index cd9244025c7f..000000000000
--- a/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-20030510-r1.ebuild,v 1.7 2005/01/22 04:19:38 trapni Exp $
-
-inherit eutils
-
-DESCRIPTION="Basic authentication for Apache using a MySQL database"
-HOMEPAGE="http://modauthmysql.sourceforge.net/"
-
-S=${WORKDIR}/${PN}
-SRC_URI="mirror://sourceforge/modauthmysql/${PN}.tgz"
-DEPEND="dev-db/mysql
- net-www/apache
- apache2? ( >=net-www/apache-2* )"
-RDEPEND=""
-LICENSE="Apache-1.1"
-KEYWORDS="~x86"
-IUSE="apache2"
-SLOT="0"
-
-if use apache2 ; then
- APXS="apxs2 -D APACHE2"
- DESTDIR=/usr/lib/apache2-extramodules
- CONFDIR=/etc/apache2/conf/modules.d
-else
- APXS="apxs -D APACHE1"
- DESTDIR=/usr/lib/apache-extramodules
- CONFDIR=/etc/apache/conf/addon-modules
-fi
-
-src_compile() {
- epatch ${FILESDIR}/mod_auth_mysql.patch || die
- $APXS -c ${PN}.c -I/usr/include/mysql -lmysqlclient -lm -lz || die
-}
-
-src_install() {
- exeinto $DESTDIR
- doexe ${PN}.so
- insinto ${CONFDIR}
- doins ${FILESDIR}/mod_auth_mysql.conf
- cat mod_auth_mysql.c | head -n81 \
- | cut -c 4- > mod_auth_mysql.txt
- dodoc ${FILESDIR}/mod_auth_mysql.conf \
- README
-}
-
-pkg_postinst() {
- if use apache2; then
- einfo "Please add '-D AUTH_MYSQL' to your /etc/conf.d/apache2 APACHE2_OPTS setting"
- else
- einfo "Please add '-D AUTH_MYSQL' to your /etc/conf.d/apache APACHE_OPTS setting"
- fi
-}