summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/mod_tcl/mod_tcl-1.0.ebuild')
-rw-r--r--net-www/mod_tcl/mod_tcl-1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-www/mod_tcl/mod_tcl-1.0.ebuild b/net-www/mod_tcl/mod_tcl-1.0.ebuild
new file mode 100644
index 000000000000..6f763fb748bf
--- /dev/null
+++ b/net-www/mod_tcl/mod_tcl-1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_tcl/mod_tcl-1.0.ebuild,v 1.1 2002/11/28 20:49:57 woodchip Exp $
+
+inherit eutils
+
+DESCRIPTION="An Apache2 DSO providing an embedded Tcl interpreter"
+HOMEPAGE="http://tcl.apache.org/mod_tcl/"
+
+S=${WORKDIR}/${P}
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+DEPEND="dev-lang/tcl =net-www/apache-2*"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+src_compile() {
+ mv tcl_core.c ${PN}.c
+ apxs2 -c -Wl,-ltcl -DHAVE_TCL_H ${PN}.c tcl_cmds.c tcl_misc.c || die
+}
+
+src_install() {
+ exeinto /usr/lib/apache2-extramodules
+ doexe .libs/${PN}.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/27_mod_tcl.conf
+ dodoc ${FILESDIR}/27_mod_tcl.conf
+ dodoc AUTHORS INSTALL NEWS README test_script.tm
+}