summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/wwwoffle/wwwoffle-2.7g.ebuild')
-rw-r--r--net-www/wwwoffle/wwwoffle-2.7g.ebuild75
1 files changed, 34 insertions, 41 deletions
diff --git a/net-www/wwwoffle/wwwoffle-2.7g.ebuild b/net-www/wwwoffle/wwwoffle-2.7g.ebuild
index 8296c16e5b28..3084c149c410 100644
--- a/net-www/wwwoffle/wwwoffle-2.7g.ebuild
+++ b/net-www/wwwoffle/wwwoffle-2.7g.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/wwwoffle/wwwoffle-2.7g.ebuild,v 1.2 2003/02/13 15:45:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/wwwoffle/wwwoffle-2.7g.ebuild,v 1.3 2003/09/06 01:54:09 msterret Exp $
S=${WORKDIR}/${P}
@@ -14,59 +14,52 @@ KEYWORDS="x86 ~sparc "
SLOT="0"
LICENSE="GPL-2"
-DEPEND="sys-devel/flex
+DEPEND="sys-devel/flex
sys-libs/zlib
sys-devel/gcc
virtual/glibc"
src_compile() {
-
- local myconf
- use ipv6 && myconf="$myconf --with-ipv6" || myconf="$myconf --without-ipv6"
- ./configure $myconf --prefix=/usr --with-confdir=/etc || die
-
- emake || die
-
+ local myconf
+ use ipv6 && myconf="$myconf --with-ipv6" || myconf="$myconf --without-ipv6"
+ ./configure $myconf --prefix=/usr --with-confdir=/etc || die
+
+ emake || die
}
src_install () {
-
- # Install the files
- make prefix=${D}/usr SPOOLDIR=${D}/var/spool/wwwoffle CONFDIR=${D}/etc install || die
-
- cd ${D}/etc
- mv wwwoffle.conf 1
- sed -e "s:${D}::" 1 > wwwoffle.conf
- rm 1
-
- # Install the wwwoffled init script
- exeinto /etc/init.d
- doexe ${FILESDIR}/{wwwoffled-online,wwwoffled}
-
- # someday i'll make it use the file in /etc. for now we at least get
- # config file protection this way.
- dosym /etc/wwwoffle.conf /var/spool/wwwoffle/wwwoffle.conf
-
-}
+ # Install the files
+ make prefix=${D}/usr SPOOLDIR=${D}/var/spool/wwwoffle CONFDIR=${D}/etc install || die
-pkg_preinst() {
+ cd ${D}/etc
+ mv wwwoffle.conf 1
+ sed -e "s:${D}::" 1 > wwwoffle.conf
+ rm 1
- source /etc/init.d/functions.sh
- if [ -L ${svcdir}/started/wwwoffled ]; then
- einfo "The wwwoffled init script is running. I'll stop it, merge the new files and
-restart the script."
- /etc/init.d/wwwoffled stop
- touch ${T}/restart
- fi
+ # Install the wwwoffled init script
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/{wwwoffled-online,wwwoffled}
+ # someday i'll make it use the file in /etc. for now we at least get
+ # config file protection this way.
+ dosym /etc/wwwoffle.conf /var/spool/wwwoffle/wwwoffle.conf
+}
+
+pkg_preinst() {
+ source /etc/init.d/functions.sh
+ if [ -L ${svcdir}/started/wwwoffled ]; then
+ einfo "The wwwoffled init script is running. I'll stop it, merge the new files and
+ restart the script."
+ /etc/init.d/wwwoffled stop
+ touch ${T}/restart
+ fi
}
pkg_postinst() {
-
- if [ -f "${T}/restart" ]; then
- einfo "Starting the wwwoffled initscript again..."
- /etc/init.d/wwwoffled start
- rm ${T}/restart
- fi
+ if [ -f "${T}/restart" ]; then
+ einfo "Starting the wwwoffled initscript again..."
+ /etc/init.d/wwwoffled start
+ rm ${T}/restart
+ fi
}