summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-zope/zope-event/zope-event-3.5.0.1.ebuild')
-rw-r--r--net-zope/zope-event/zope-event-3.5.0.1.ebuild18
1 files changed, 4 insertions, 14 deletions
diff --git a/net-zope/zope-event/zope-event-3.5.0.1.ebuild b/net-zope/zope-event/zope-event-3.5.0.1.ebuild
index 91ba4a5b3497..a10a9b17f5a0 100644
--- a/net-zope/zope-event/zope-event-3.5.0.1.ebuild
+++ b/net-zope/zope-event/zope-event-3.5.0.1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-event/zope-event-3.5.0.1.ebuild,v 1.2 2010/10/30 19:00:41 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-event/zope-event-3.5.0.1.ebuild,v 1.3 2010/12/18 20:17:11 arfrever Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
inherit distutils
@@ -18,10 +19,9 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="ZPL"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="test"
+IUSE=""
-DEPEND="dev-python/setuptools
- test? ( dev-python/nose )"
+DEPEND="dev-python/setuptools"
RDEPEND=""
S="${WORKDIR}/${MY_P}"
@@ -29,16 +29,6 @@ S="${WORKDIR}/${MY_P}"
DOCS="README.txt"
PYTHON_MODNAME="${PN/-//}"
-src_test() {
- testing() {
- # Future versions of dev-python/nose will support Python 3.
- [[ "${PYTHON_ABI}" == 3.* ]] && return
-
- PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
src_install() {
distutils_src_install
newdoc src/zope/event/README.txt event-README.txt