summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-zope/zope-security/zope-security-3.7.2.ebuild')
-rw-r--r--net-zope/zope-security/zope-security-3.7.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-zope/zope-security/zope-security-3.7.2.ebuild b/net-zope/zope-security/zope-security-3.7.2.ebuild
new file mode 100644
index 000000000000..2cf47767e45d
--- /dev/null
+++ b/net-zope/zope-security/zope-security-3.7.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-security/zope-security-3.7.2.ebuild,v 1.1 2009/11/13 18:18:04 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Zope3 Security Framework"
+HOMEPAGE="http://pypi.python.org/pypi/zope.security"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/pytz
+ dev-python/restrictedpython
+ net-zope/zope-component
+ net-zope/zope-configuration
+ net-zope/zope-exceptions
+ net-zope/zope-i18nmessageid
+ net-zope/zope-interface
+ net-zope/zope-location
+ net-zope/zope-proxy
+ net-zope/zope-schema"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${PN/-//}"
+DOCS="CHANGES.txt README.txt"
+
+src_install() {
+ distutils_src_install
+
+ # Don't install C sources.
+ find "${D}" -name "*.c" | xargs rm -f
+}