summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/esorex/esorex-3.9.6-r1.ebuild')
-rw-r--r--sci-astronomy/esorex/esorex-3.9.6-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-astronomy/esorex/esorex-3.9.6-r1.ebuild b/sci-astronomy/esorex/esorex-3.9.6-r1.ebuild
new file mode 100644
index 000000000000..f76379e94506
--- /dev/null
+++ b/sci-astronomy/esorex/esorex-3.9.6-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/esorex/esorex-3.9.6-r1.ebuild,v 1.1 2012/08/05 17:23:27 bicatali Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="ESO Recipe Execution Tool to exec cpl scripts"
+HOMEPAGE="http://www.eso.org/sci/software/cpl/esorex.html"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/pipelines/libraries/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=">=sci-astronomy/cpl-6"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-autoconf-26.patch
+ "${FILESDIR}"/${P}-use-system-ltdl.patch
+ "${FILESDIR}"/${P}-use-shared-libs.patch
+ "${FILESDIR}"/${P}-set-default-plugin-path.patch
+ "${FILESDIR}"/${P}-move-rcfile-to-etc.patch
+)
+
+export CPLDIR="${EPREFIX}/usr"
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}