summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/phylip/phylip-3.63.ebuild')
-rw-r--r--sci-biology/phylip/phylip-3.63.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-biology/phylip/phylip-3.63.ebuild b/sci-biology/phylip/phylip-3.63.ebuild
new file mode 100644
index 000000000000..14e3b3d87db3
--- /dev/null
+++ b/sci-biology/phylip/phylip-3.63.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/phylip/phylip-3.63.ebuild,v 1.1 2004/12/23 21:37:02 ribosome Exp $
+
+inherit gcc
+
+DESCRIPTION="PHYLIP - The PHYLogeny Inference Package"
+HOMEPAGE="http://evolution.genetics.washington.edu/phylip.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="freedist"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~ppc-macos"
+IUSE=""
+
+DEPEND="virtual/libc
+ virtual/x11"
+
+S=${WORKDIR}/${P}/src
+
+src_compile() {
+ sed -i -e "s/CFLAGS =/CFLAGS = ${CFLAGS}/" Makefile
+ sed -i -e "s/CC = cc/CC = $(gcc-getCC)/" Makefile
+ sed -i -e "s/DC = cc/DC = $(gcc-getCC)/" Makefile
+ mkdir ../fonts
+ emake -j1 all put || die
+ mv ../exe/font* ../fonts
+}
+
+src_install()
+{
+ cd ${WORKDIR}/${P}
+
+ dobin exe/*
+
+ dohtml phylip.html
+ insinto /usr/share/doc/${PF}/html/doc
+ doins doc/*
+
+ insinto /usr/share/${PN}/fonts
+ doins fonts/*
+}