summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/qrna/qrna-2.0.2c.ebuild')
-rw-r--r--sci-biology/qrna/qrna-2.0.2c.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-biology/qrna/qrna-2.0.2c.ebuild b/sci-biology/qrna/qrna-2.0.2c.ebuild
new file mode 100644
index 000000000000..5cb56586819f
--- /dev/null
+++ b/sci-biology/qrna/qrna-2.0.2c.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/qrna/qrna-2.0.2c.ebuild,v 1.1 2004/12/23 15:28:29 ribosome Exp $
+
+DESCRIPTION="Prototype ncRNA genefinder"
+HOMEPAGE="http://www.genetics.wustl.edu/eddy/software/"
+SRC_URI="ftp://ftp.genetics.wustl.edu/pub/eddy/software/qrna.tar.Z"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="x86 ~ppc ~amd64"
+IUSE="perl"
+
+DEPEND="perl? ( dev-lang/perl )
+ virtual/libc"
+
+src_compile () {
+ cd ${S}/squid
+ emake || die
+ cd ${S}/src
+ emake || die
+}
+
+src_install () {
+ dobin src/qrna
+ use perl && dobin scripts/*
+
+ newdoc 00README README
+ insinto /usr/share/doc/${PF}
+ doins documentation/*
+
+ insinto /usr/share/${PN}/data
+ doins lib/*
+ insinto /usr/share/${PN}/demos
+ doins Demos/*
+
+ # Sets the path to the QRNA data files.
+ insinto /etc/env.d
+ doins ${FILESDIR}/26qrna
+}