summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/busybox/busybox-0.60.3-r1.ebuild')
-rw-r--r--sys-apps/busybox/busybox-0.60.3-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/busybox/busybox-0.60.3-r1.ebuild b/sys-apps/busybox/busybox-0.60.3-r1.ebuild
new file mode 100644
index 000000000000..f623e409725e
--- /dev/null
+++ b/sys-apps/busybox/busybox-0.60.3-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.60.3-r1.ebuild,v 1.1 2003/04/03 17:28:47 mholzer Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Utilities for rescue and embedded systems"
+SRC_URI="http://www.busybox.net/downloads/${P}.tar.gz"
+HOMEPAGE="http://www.busybox.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc "
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cp ${FILESDIR}/Config.h-${PV}-cd ${S}/Config.h
+ # I did not include the msh patch since I don't know if it will
+ # break stuff, I compile ash anyway, and it's in CVS
+}
+
+src_compile() {
+ local myconf
+ use static && myconf="${myconf} DOSTATIC=true"
+ emake ${myconf} || die
+}
+
+src_install() {
+ into /
+ dobin busybox
+ into /usr
+ dodoc AUTHORS Changelog* INSTALL LICENSE README TODO
+
+ docinto scripts
+ dodoc busybox.links
+
+ cd docs
+ doman *.1
+ docinto txt
+ dodoc *.txt
+ docinto pod
+ dodoc *.pod
+ dohtml *.html
+ dohtml *.sgml
+
+ cd ../scripts
+ docinto scripts
+ dodoc inittab
+ dodoc depmod.pl
+}