summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/busybox/busybox-1.2.0.ebuild')
-rw-r--r--sys-apps/busybox/busybox-1.2.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-apps/busybox/busybox-1.2.0.ebuild b/sys-apps/busybox/busybox-1.2.0.ebuild
index 0f045df907b3..d2cd657b0d23 100644
--- a/sys-apps/busybox/busybox-1.2.0.ebuild
+++ b/sys-apps/busybox/busybox-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.0.ebuild,v 1.3 2006/07/10 17:54:07 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.0.ebuild,v 1.4 2006/07/15 02:51:34 vapier Exp $
inherit eutils flag-o-matic
@@ -126,8 +126,8 @@ src_unpack() {
src_compile() {
busybox_set_env
- use ppc64 && CFLAGS="${CFLAGS} -mminimal-toc `test-flags-CC -fno-stack-protector`"
- use ppc && CFLAGS="${CFLAGS} `test-flags-CC -fno-stack-protector`"
+ use ppc64 && append-flags -mminimal-toc $(test-flags-CC -fno-stack-protector)
+ use ppc && append-flags $(test-flags-CC -fno-stack-protector)
emake CROSS="${CROSS}" busybox || die "build failed"
if ! use static ; then
mv busybox_unstripped{,.bak}