summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/file/file-5.05.ebuild')
-rw-r--r--sys-apps/file/file-5.05.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-apps/file/file-5.05.ebuild b/sys-apps/file/file-5.05.ebuild
index 2df53eaee2f5..53916a9a57ab 100644
--- a/sys-apps/file/file-5.05.ebuild
+++ b/sys-apps/file/file-5.05.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.05.ebuild,v 1.8 2011/03/01 14:53:26 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.05.ebuild,v 1.9 2011/04/04 16:47:00 ssuominen Exp $
PYTHON_DEPEND="python? *"
SUPPORT_PYTHON_ABIS="1"
@@ -16,7 +16,7 @@ SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
LICENSE="as-is"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="python"
+IUSE="python static-libs"
PYTHON_MODNAME="magic.py"
@@ -35,7 +35,7 @@ src_compile() {
# file uses things like strndup() and wcwidth()
append-flags -D_GNU_SOURCE
- econf || die
+ econf $(use_enable static-libs static)
emake || die
use python && cd python && distutils_src_compile
@@ -46,6 +46,7 @@ src_install() {
dodoc ChangeLog MAINT README
use python && cd python && distutils_src_install
+ use static-libs || rm -f "${D}"/usr/lib*/libmagic.la
}
pkg_postinst() {