summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hwloc/hwloc-1.2.1.ebuild')
-rw-r--r--sys-apps/hwloc/hwloc-1.2.1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-apps/hwloc/hwloc-1.2.1.ebuild b/sys-apps/hwloc/hwloc-1.2.1.ebuild
index f9c5135c3b15..662743d86b54 100644
--- a/sys-apps/hwloc/hwloc-1.2.1.ebuild
+++ b/sys-apps/hwloc/hwloc-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.2.1.ebuild,v 1.2 2011/09/01 16:20:55 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.2.1.ebuild,v 1.3 2011/12/07 22:01:17 binki Exp $
EAPI="4"
@@ -24,6 +24,11 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
numa? ( sys-process/numactl )"
+pkg_setup() {
+ # Fix bug #393467, hwloc ignores PKG_CONFIG environment variable.
+ [[ ${PKG_CONFIG} ]] && export HWLOC_PKG_CONFIG=${PKG_CONFIG}
+}
+
src_configure() {
econf \
--docdir="${EPREFIX}/usr/share/doc/${P}" \