summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd/systemd-206-r3.ebuild')
-rw-r--r--sys-apps/systemd/systemd-206-r3.ebuild33
1 files changed, 10 insertions, 23 deletions
diff --git a/sys-apps/systemd/systemd-206-r3.ebuild b/sys-apps/systemd/systemd-206-r3.ebuild
index 1e1f041771a5..5258a0b3378c 100644
--- a/sys-apps/systemd/systemd-206-r3.ebuild
+++ b/sys-apps/systemd/systemd-206-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-206-r3.ebuild,v 1.5 2013/08/11 21:34:00 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-206-r3.ebuild,v 1.6 2013/08/28 11:01:45 pacho Exp $
EAPI=5
@@ -330,20 +330,6 @@ multilib_src_install_all() {
done
}
-optfeature() {
- local i desc=${1} text
- shift
-
- text=" [\e[1m$(has_version ${1} && echo I || echo ' ')\e[0m] ${1}"
- shift
-
- for i; do
- elog "${text}"
- text="& [\e[1m$(has_version ${1} && echo I || echo ' ')\e[0m] ${1}"
- done
- elog "${text} (${desc})"
-}
-
pkg_postinst() {
# for udev rules
enewgroup dialout
@@ -369,17 +355,18 @@ pkg_postinst() {
fcaps cap_dac_override,cap_sys_ptrace=ep usr/bin/systemd-detect-virt
if [[ ! -L "${ROOT}"/etc/mtab ]]; then
- ewarn "Upstream suggests that the /etc/mtab file should be a symlink to /proc/mounts."
- ewarn "It is known to cause users being unable to unmount user mounts. If you don't"
- ewarn "require that specific feature, please call:"
- ewarn " $ ln -sf '${ROOT}proc/self/mounts' '${ROOT}etc/mtab'"
+ ewarn "Upstream mandates the /etc/mtab file should be a symlink to /proc/mounts."
+ ewarn "Not having it is not supported by upstream and will cause tools like 'df'"
+ ewarn "and 'mount' to not work properly. Please run:"
+ ewarn " # ln -sf '${ROOT}proc/self/mounts' '${ROOT}etc/mtab'"
ewarn
fi
- elog "To get additional features, a number of optional runtime dependencies may"
- elog "be installed:"
- optfeature 'for GTK+ systemadm UI and gnome-ask-password-agent' \
- 'sys-apps/systemd-ui'
+ if ! has_version sys-apps/systemd-ui; then
+ elog "To get additional features, a number of optional runtime dependencies may"
+ elog "be installed:"
+ elog "- sys-apps/systemd-ui: for GTK+ systemadm UI and gnome-ask-password-agent"
+ fi
}
pkg_prerm() {