summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ucspi-proxy/ucspi-proxy-0.97-r1.ebuild')
-rw-r--r--sys-apps/ucspi-proxy/ucspi-proxy-0.97-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/ucspi-proxy/ucspi-proxy-0.97-r1.ebuild b/sys-apps/ucspi-proxy/ucspi-proxy-0.97-r1.ebuild
new file mode 100644
index 000000000000..0a22d7896709
--- /dev/null
+++ b/sys-apps/ucspi-proxy/ucspi-proxy-0.97-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ucspi-proxy/ucspi-proxy-0.97-r1.ebuild,v 1.1 2008/07/25 19:01:56 bangert Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A proxy program for two connections set up by a UCSPI server and a UCSPI client."
+HOMEPAGE="http://untroubled.org/ucspi-proxy/"
+SRC_URI="${HOMEPAGE}archive/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-libs/bglibs-1.025
+ sys-apps/sed"
+RDEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e '/^>bin$/ac:::755::ucspi-proxy' INSTHIER
+}
+
+src_compile() {
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ echo "${D}/usr/bin" > conf-bin
+ echo "${D}/usr/share/man/" > conf-man
+ echo "/usr/include/bglibs/" > conf-bgincs
+ echo "/usr/lib/bglibs/" > conf-bglibs
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc ANNOUNCEMENT NEWS README TODO
+}