summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/util-linux')
-rw-r--r--sys-apps/util-linux/ChangeLog6
-rw-r--r--sys-apps/util-linux/files/util-linux-2.13.1-no-a.out.patch26
-rw-r--r--sys-apps/util-linux/util-linux-2.13.1.1.ebuild5
3 files changed, 34 insertions, 3 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index 557f56dd2049..79faea6ca084 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.238 2008/04/28 17:01:56 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.239 2008/06/07 17:46:28 vapier Exp $
+
+ 07 Jun 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/util-linux-2.13.1-no-a.out.patch, util-linux-2.13.1.1.ebuild:
+ Do not rely on a.out.h #221939 by Mart Raudsepp.
28 Apr 2008; Tobias Scherbaum <dertobi123@gentoo.org>
util-linux-2.13.1.1.ebuild:
diff --git a/sys-apps/util-linux/files/util-linux-2.13.1-no-a.out.patch b/sys-apps/util-linux/files/util-linux-2.13.1-no-a.out.patch
new file mode 100644
index 000000000000..d871575e4a3d
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.13.1-no-a.out.patch
@@ -0,0 +1,26 @@
+http://bugs.gentoo.org/221939
+http://article.gmane.org/gmane.linux.utilities.util-linux-ng/1463
+
+--- a/text-utils/more.c
++++ b/text-utils/more.c
+@@ -54,7 +54,6 @@
+ #include <sys/stat.h>
+ #include <sys/file.h>
+ #include <sys/wait.h>
+-#include <a.out.h>
+ #include "xstrncpy.h"
+ #include "nls.h"
+ #include "widechar.h"
+@@ -546,9 +545,9 @@ magic(f, fs)
+
+ if (fread(twobytes, 2, 1, f) == 1) {
+ switch(twobytes[0] + (twobytes[1]<<8)) {
+- case OMAGIC: /* 0407 */
+- case NMAGIC: /* 0410 */
+- case ZMAGIC: /* 0413 */
++ case 0407: /* a.out obj */
++ case 0410: /* a.out exec */
++ case 0413: /* a.out demand exec */
+ case 0405:
+ case 0411:
+ case 0177545:
diff --git a/sys-apps/util-linux/util-linux-2.13.1.1.ebuild b/sys-apps/util-linux/util-linux-2.13.1.1.ebuild
index 656fd83c5893..8fb07f02ae9d 100644
--- a/sys-apps/util-linux/util-linux-2.13.1.1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.13.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.13.1.1.ebuild,v 1.7 2008/04/28 17:01:56 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.13.1.1.ebuild,v 1.8 2008/06/07 17:46:28 vapier Exp $
EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
inherit eutils
@@ -21,7 +21,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
IUSE="crypt loop-aes nls old-linux selinux slang unicode"
RDEPEND="!sys-process/schedutils
@@ -46,6 +46,7 @@ src_unpack() {
use loop-aes && epatch "${WORKDIR}"/loop-AES-*/util-linux-ng-*.diff
use unicode && sed -i 's:-lncurses:-lncursesw:' */Makefile.in #208976
epatch "${FILESDIR}"/${PN}-2.13-ioprio-syscalls.patch #190613
+ epatch "${FILESDIR}"/${PN}-2.13.1-no-a.out.patch #221939
fi
}