summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/policykit-qt/ChangeLog8
-rw-r--r--sys-auth/policykit-qt/policykit-qt-0.9.3.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-auth/policykit-qt/ChangeLog b/sys-auth/policykit-qt/ChangeLog
index 1fdff8037bcf..6159dfd20184 100644
--- a/sys-auth/policykit-qt/ChangeLog
+++ b/sys-auth/policykit-qt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/policykit-qt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/policykit-qt/ChangeLog,v 1.11 2010/01/19 00:51:48 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/policykit-qt/ChangeLog,v 1.12 2010/02/08 22:13:06 alexxy Exp $
+
+*policykit-qt-0.9.3 (08 Feb 2010)
+
+ 08 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org>
+ +policykit-qt-0.9.3.ebuild:
+ Version bump
19 Jan 2010; Jeroen Roovers <jer@gentoo.org> policykit-qt-0.9.2.ebuild:
Stable for HPPA too.
diff --git a/sys-auth/policykit-qt/policykit-qt-0.9.3.ebuild b/sys-auth/policykit-qt/policykit-qt-0.9.3.ebuild
new file mode 100644
index 000000000000..1fe1b0578a19
--- /dev/null
+++ b/sys-auth/policykit-qt/policykit-qt-0.9.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/policykit-qt/policykit-qt-0.9.3.ebuild,v 1.1 2010/02/08 22:13:06 alexxy Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+MY_P="polkit-qt-${PV}"
+
+DESCRIPTION="PolicyKit Qt4 API wrapper library."
+HOMEPAGE="http://kde.org/"
+SRC_URI="mirror://kde/stable/apps/KDE4.x/admin/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="debug examples"
+
+RDEPEND="
+ >=sys-auth/policykit-0.8
+ >=x11-libs/qt-gui-4.4:4[dbus]
+"
+DEPEND="${RDEPEND}
+ kde-base/automoc
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_build examples)"
+
+ cmake-utils_src_configure
+}