summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/lilo/lilo-22.5.8-r2.ebuild')
-rw-r--r--sys-boot/lilo/lilo-22.5.8-r2.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/sys-boot/lilo/lilo-22.5.8-r2.ebuild b/sys-boot/lilo/lilo-22.5.8-r2.ebuild
index e14408add1e9..85c839348aa6 100644
--- a/sys-boot/lilo/lilo-22.5.8-r2.ebuild
+++ b/sys-boot/lilo/lilo-22.5.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.5.8-r2.ebuild,v 1.3 2004/04/21 02:15:54 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.5.8-r2.ebuild,v 1.4 2004/05/12 12:11:54 pappy Exp $
inherit mount-boot eutils flag-o-matic
@@ -53,18 +53,13 @@ src_unpack() {
}
src_compile() {
- # add the hardened-gcc compiler flag for building its assembler parts ;-)
- if has_version 'sys-devel/hardened-gcc'
- then
- export CC="${CC:=gcc} -yet_exec"
- find ${W} -type f -name "Makefile" -exec sed -i "s:CC=cc:CC=${CC}:" {} \;
- fi
- # Fixes borkage with hardened gccs and people who have -fPIC, etc in their specs.
- has_pic && CC="${CC} `test_flag -nopie` `test_flag -yet_exec`"
+ # hardened automatic PIC plus PIE building should be suppressed
+ # because of assembler instructions that cannot be compiled PIC
+ HARDENED_CFLAGS="`test_flag -fno-pic` `test_flag -nopie`"
# Do not use custom CFLAGS for stability reasons
- emake CC="${CC:=gcc}" lilo || die
+ emake CC="${CC:=gcc} ${HARDENED_CFLAGS}" lilo || die
}
src_install() {