summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/binutils-hppa64')
-rw-r--r--sys-devel/binutils-hppa64/binutils-hppa64-2.17.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-devel/binutils-hppa64/binutils-hppa64-2.17.ebuild b/sys-devel/binutils-hppa64/binutils-hppa64-2.17.ebuild
index 2d463eebe9d0..0fba5ab3a52a 100644
--- a/sys-devel/binutils-hppa64/binutils-hppa64-2.17.ebuild
+++ b/sys-devel/binutils-hppa64/binutils-hppa64-2.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-hppa64/binutils-hppa64-2.17.ebuild,v 1.1 2006/08/27 08:30:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-hppa64/binutils-hppa64-2.17.ebuild,v 1.2 2006/10/26 04:11:30 vapier Exp $
export CTARGET=hppa64-${CHOST#*-}
@@ -12,3 +12,11 @@ inherit toolchain-binutils
DESCRIPTION="binutils package for building 64bit kernels on HPPA"
KEYWORDS="-* ~hppa"
+
+src_install() {
+ toolchain-binutils_src_install
+
+ # tweak the default fake list a little bit
+ cd "${D}"/etc/env.d/binutils
+ sed -i '/FAKE_TARGETS=/s:"$: hppa64-linux":' ${CTARGET}-${BVER} || die
+}