summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/libtool/libtool-2.2.10.ebuild')
-rw-r--r--sys-devel/libtool/libtool-2.2.10.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/sys-devel/libtool/libtool-2.2.10.ebuild b/sys-devel/libtool/libtool-2.2.10.ebuild
deleted file mode 100644
index fb6310672a29..000000000000
--- a/sys-devel/libtool/libtool-2.2.10.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-2.2.10.ebuild,v 1.14 2012/04/09 00:32:11 vapier Exp $
-
-EAPI="2" #356089
-
-LIBTOOLIZE="true" #225559
-WANT_LIBTOOL="none"
-inherit eutils autotools multilib
-
-DESCRIPTION="A shared library tool for developers"
-HOMEPAGE="http://www.gnu.org/software/libtool/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.lzma"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="test vanilla"
-
-RDEPEND="sys-devel/gnuconfig
- >=sys-devel/autoconf-2.62
- >=sys-devel/automake-1.10.1
- !=sys-devel/automake-1.10
- !=sys-devel/libtool-2*:1.5"
-DEPEND="${RDEPEND}
- test? ( !<sys-devel/binutils-2.20 )
- app-arch/xz-utils"
-
-src_prepare() {
- if ! use vanilla ; then
- cd libltdl/m4
- epatch "${FILESDIR}"/1.5.20/${PN}-1.5.20-use-linux-version-in-fbsd.patch #109105
- cd ..
- AT_NOELIBTOOLIZE=yes eautoreconf
- cd ..
- AT_NOELIBTOOLIZE=yes eautoreconf
- fi
-}
-
-src_configure() {
- # the libtool script uses bash code in it and at configure time, tries
- # to find a bash shell. if /bin/sh is bash, it uses that. this can
- # cause problems for people who switch /bin/sh on the fly to other
- # shells, so just force libtool to use /bin/bash all the time.
- export CONFIG_SHELL=/bin/bash
-
- default
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog* NEWS README THANKS TODO doc/PLATFORMS
-
- for x in $(find "${D}" -name config.guess -o -name config.sub) ; do
- rm -f "${x}" ; ln -sf /usr/share/gnuconfig/${x##*/} "${x}"
- done
-}
-
-pkg_preinst() {
- preserve_old_lib /usr/$(get_libdir)/libltdl.so.3
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /usr/$(get_libdir)/libltdl.so.3
-}