summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-freebsd/freebsd-usbin/files/freebsd-usbin-fixmakefiles.patch')
-rw-r--r--sys-freebsd/freebsd-usbin/files/freebsd-usbin-fixmakefiles.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-freebsd/freebsd-usbin/files/freebsd-usbin-fixmakefiles.patch b/sys-freebsd/freebsd-usbin/files/freebsd-usbin-fixmakefiles.patch
new file mode 100644
index 000000000000..f38f2770291a
--- /dev/null
+++ b/sys-freebsd/freebsd-usbin/files/freebsd-usbin-fixmakefiles.patch
@@ -0,0 +1,34 @@
+diff -ur usr.sbin.orig/pcvt/keycap/Makefile usr.sbin/pcvt/keycap/Makefile
+--- usr.sbin.orig/pcvt/keycap/Makefile Thu Apr 7 22:01:55 2005
++++ usr.sbin/pcvt/keycap/Makefile Thu Apr 7 22:07:37 2005
+@@ -18,6 +18,7 @@
+ #CLEANFILES+= keycap.0 man5/keycap.0
+
+ beforeinstall:
++ ${INSTALL} -d ${DESTDIR}${CAPPATH}
+ ${INSTALL} -o ${BINOWN} -g ${BINGRP} -m ${NOBINMODE} \
+ ${.CURDIR}/${KEYCAPSRC} ${DESTDIR}${CAPPATH}
+
+diff -ur usr.sbin.orig/sysinstall/Makefile usr.sbin/sysinstall/Makefile
+--- usr.sbin.orig/sysinstall/Makefile Thu Apr 7 22:01:56 2005
++++ usr.sbin/sysinstall/Makefile Thu Apr 7 22:05:33 2005
+@@ -84,7 +84,7 @@
+ keymap.h:
+ rm -f keymap.tmp
+ for map in ${KEYMAPS} ; do \
+- KEYMAP_PATH=${.CURDIR}/../../share/syscons/keymaps \
++ KEYMAP_PATH=/usr/share/syscons/keymaps \
+ kbdcontrol -L $$map | \
+ sed -e '/^static accentmap_t/,$$d' >> keymap.tmp ; \
+ done
+diff -ur usr.sbin.orig/ypserv/Makefile usr.sbin/ypserv/Makefile
+--- usr.sbin.orig/ypserv/Makefile Thu Apr 7 22:01:55 2005
++++ usr.sbin/ypserv/Makefile Thu Apr 7 22:06:07 2005
+@@ -31,6 +31,7 @@
+ ${RPCGEN} -h -o ${.TARGET} ${RPCDIR}/yp.x
+
+ afterinstall:
++ ${INSTALL} -d ${DESTDIR}/var/yp
+ ${INSTALL} -o ${BINOWN} -g ${BINGRP} -m 444 \
+ ${.CURDIR}/Makefile.yp \
+ ${DESTDIR}/var/yp/Makefile.dist