summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/btrfs/btrfs-0.16.ebuild')
-rw-r--r--sys-fs/btrfs/btrfs-0.16.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/sys-fs/btrfs/btrfs-0.16.ebuild b/sys-fs/btrfs/btrfs-0.16.ebuild
deleted file mode 100644
index 15b73c1992cd..000000000000
--- a/sys-fs/btrfs/btrfs-0.16.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/btrfs-0.16.ebuild,v 1.1 2008/08/06 04:04:52 lavajoe Exp $
-
-inherit eutils linux-mod
-
-DESCRIPTION="A checksumming copy-on-write filesystem"
-HOMEPAGE="http://btrfs.wiki.kernel.org/"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/people/mason/btrfs/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-pkg_setup()
-{
- linux-mod_pkg_setup
-
- BUILD_TARGETS="all"
- BUILD_PARAMS="KERNELDIR=${KV_OUT_DIR}"
- MODULE_NAMES="btrfs(fs:${S}/"
-
- if ! kernel_is 2 6; then
- eerror "Need a 2.6 kernel to compile against!"
- die "Need a 2.6 kernel to compile against!"
- fi
-
- if ! linux_chkconfig_present LIBCRC32C; then
- eerror "You need to enable LIBCRC32C in your kernel!"
- die "You need to enable LIBCRC32C in your kernel!"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Apply hot fixes
- #epatch "${FILESDIR}/${P}-hotfix.patch"
-}
-
-src_install()
-{
- linux-mod_src_install
-
- dodoc INSTALL TODO
-}
-
-pkg_postinst() {
- linux-mod_pkg_postinst
-
- ewarn "WARNING: Btrfs is under heavy development and is not suitable for"
- ewarn " any uses other than benchmarking and review."
- ewarn " The Btrfs disk format is not yet finalized."
- ewarn
- ewarn " Also, it is highly recommended that the versions of"
- ewarn " btrfs and btrfs-progs match."
- ewarn
- ewarn "Note: THE DISK FORMAT HAS CHANGED!"
- ewarn " You must backup your data and re-create your btrfs"
- ewarn " filesystem(s) for use with this version."
-}