summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-2.4.18.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.4.18.ebuild108
1 files changed, 0 insertions, 108 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-2.4.18.ebuild b/sys-kernel/linux-headers/linux-headers-2.4.18.ebuild
deleted file mode 100644
index 8e0f404b66de..000000000000
--- a/sys-kernel/linux-headers/linux-headers-2.4.18.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.18.ebuild,v 1.16 2004/03/14 06:42:18 seemant Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-#we use this next variable to avoid duplicating stuff on cvs
-GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
-OKV=2.4.18
-KV=2.4.18
-S=${WORKDIR}/linux-${KV}
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 alpha"
-
-#These are *stock* 2.4.18 headers, for niceness.
-
-DESCRIPTION="Full sources for the Gentoo Linux kernel"
-SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2"
-PROVIDE="virtual/kernel virtual/os-headers"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
-
-if [ $PN = "linux-sources" ] && [ -z "`use build`" ]
-then
- #sys-apps/kbd is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
- DEPEND=">=sys-devel/binutils-2.11.90.0.31"
- RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl virtual/modutils sys-devel/make"
-fi
-
-[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
- mv linux linux-${KV} || die
- cd ${S}
-
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die
-
- #this file is required for other things to build properly, so we autogenerate it
- make include/linux/version.h || die
-
- #fix silly permissions in tarball
- cd ${WORKDIR}
- chown -R 0:0 *
- chmod -R a+r-w+X,u+w *
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
- cd ${S}
- mv Makefile Makefile.orig
- sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
- Makefile.orig >Makefile || die # test, remove me if Makefile ok
- rm Makefile.orig
-}
-
-src_compile() {
- if [ "$PN" = "linux-headers" ]
- then
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- fi
-}
-
-src_install() {
- if [ "$PN" = "linux-sources" ]
- then
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
- else
- #linux-headers
- dodir /usr/include/linux
- cp -ax ${S}/include/linux/* ${D}/usr/include/linux
- rm -rf ${D}/usr/include/linux/modules
- dodir /usr/include/asm
- cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
- fi
-}
-
-pkg_preinst() {
- if [ "$PN" = "linux-headers" ]
- then
- [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
- [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
- true
- fi
-}
-
-pkg_postinst() {
- [ "$PN" = "linux-headers" ] && return
- cd ${ROOT}usr/src/linux-${KV}
- make mrproper
- if [ -e "${ROOT}usr/src/linux/.config" ]
- then
- cp "${ROOT}usr/src/linux/.config" .config
- #we only make dep when upgrading to a new kernel (with existing config)
- #The default setting will be selected.
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- make dep
- else
- cp "${ROOT}usr/src/linux-${KV}/arch/i386/defconfig" .config
- fi
- #remove /usr/src/linux symlink
- rm -f ${ROOT}/usr/src/linux
- #set up a new one
- ln -sf linux-${KV} ${ROOT}/usr/src/linux
-}