summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/mips-prepatch-sources')
-rw-r--r--sys-kernel/mips-prepatch-sources/ChangeLog9
-rw-r--r--sys-kernel/mips-prepatch-sources/Manifest7
-rw-r--r--sys-kernel/mips-prepatch-sources/files/digest-mips-prepatch-sources-2.4.25_pre6-r1 (renamed from sys-kernel/mips-prepatch-sources/files/digest-mips-prepatch-sources-2.4.25_pre6)0
-rw-r--r--sys-kernel/mips-prepatch-sources/files/do_munmap-fix.patch27
-rw-r--r--sys-kernel/mips-prepatch-sources/mips-prepatch-sources-2.4.25_pre6-r1.ebuild (renamed from sys-kernel/mips-prepatch-sources/mips-prepatch-sources-2.4.25_pre6.ebuild)9
5 files changed, 45 insertions, 7 deletions
diff --git a/sys-kernel/mips-prepatch-sources/ChangeLog b/sys-kernel/mips-prepatch-sources/ChangeLog
index c7f7fe98e0dd..68b4543a4cca 100644
--- a/sys-kernel/mips-prepatch-sources/ChangeLog
+++ b/sys-kernel/mips-prepatch-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/mips-prepatch-sources
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-prepatch-sources/ChangeLog,v 1.8 2004/02/10 06:57:29 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-prepatch-sources/ChangeLog,v 1.9 2004/02/18 21:56:26 kumba Exp $
+
+*mips-prepatch-sources-2.4.25_pre6-r1 (18 Feb 2004)
+
+ 18 Feb 2004; Joshua Kinard <kumba@gentoo.org>
+ mips-prepatch-sources-2.4.25_pre6-r1.ebuild,
+ mips-prepatch-sources-2.4.25_pre6.ebuild, files/do_munmap-fix.patch:
+ Added a patch to fix the recent do_munmap kernel vuln.
*mips-prepatch-sources-2.4.25_pre6 (10 Feb 2004)
diff --git a/sys-kernel/mips-prepatch-sources/Manifest b/sys-kernel/mips-prepatch-sources/Manifest
index c803dc13ec62..c2b90b81c50f 100644
--- a/sys-kernel/mips-prepatch-sources/Manifest
+++ b/sys-kernel/mips-prepatch-sources/Manifest
@@ -1,6 +1,7 @@
-MD5 a5ce475ad1df19a89d35f187407a4acb ChangeLog 2285
+MD5 0acdef48f938861cae8239eccfd3906c ChangeLog 2562
MD5 0bfb6b59036d1fe3e8075bc8879e772b metadata.xml 412
-MD5 b6e6b794c36f3011a2aac836e2138209 mips-prepatch-sources-2.4.25_pre6.ebuild 2148
+MD5 be3fcdaf5fbf685bb25204b3f415c38e mips-prepatch-sources-2.4.25_pre6-r1.ebuild 2227
MD5 d41d8cd98f00b204e9800998ecf8427e files/.keep 0
-MD5 1646cb074c99365f653d5db9416625dc files/digest-mips-prepatch-sources-2.4.25_pre6 290
+MD5 174438d215b70cad5ffb00ca8123c062 files/do_munmap-fix.patch 837
+MD5 1646cb074c99365f653d5db9416625dc files/digest-mips-prepatch-sources-2.4.25_pre6-r1 290
MD5 1f2d806ba24602d1a46129700e8fcc5d files/mipscvs-2.4.25-pre6-20040209-makefile.patch 1513
diff --git a/sys-kernel/mips-prepatch-sources/files/digest-mips-prepatch-sources-2.4.25_pre6 b/sys-kernel/mips-prepatch-sources/files/digest-mips-prepatch-sources-2.4.25_pre6-r1
index b04d6ff75229..b04d6ff75229 100644
--- a/sys-kernel/mips-prepatch-sources/files/digest-mips-prepatch-sources-2.4.25_pre6
+++ b/sys-kernel/mips-prepatch-sources/files/digest-mips-prepatch-sources-2.4.25_pre6-r1
diff --git a/sys-kernel/mips-prepatch-sources/files/do_munmap-fix.patch b/sys-kernel/mips-prepatch-sources/files/do_munmap-fix.patch
new file mode 100644
index 000000000000..e120b35b7adb
--- /dev/null
+++ b/sys-kernel/mips-prepatch-sources/files/do_munmap-fix.patch
@@ -0,0 +1,27 @@
+diff -ur linux-2.4.25-rc3/mm/mremap.c linux-2.4.25-rc4/mm/mremap.c
+--- linux-2.4.25-rc3/mm/mremap.c 2004-02-18 13:56:01.000000000 +0000
++++ linux-2.4.25-rc4/mm/mremap.c 2004-02-18 13:49:08.000000000 +0000
+@@ -258,16 +258,20 @@
+ if ((addr <= new_addr) && (addr+old_len) > new_addr)
+ goto out;
+
+- do_munmap(current->mm, new_addr, new_len);
++ ret = do_munmap(current->mm, new_addr, new_len);
++ if (ret && new_len)
++ goto out;
+ }
+
+ /*
+ * Always allow a shrinking remap: that just unmaps
+ * the unnecessary pages..
+ */
+- ret = addr;
+ if (old_len >= new_len) {
+- do_munmap(current->mm, addr+new_len, old_len - new_len);
++ ret = do_munmap(current->mm, addr+new_len, old_len - new_len);
++ if (ret && old_len != new_len)
++ goto out;
++ ret = addr;
+ if (!(flags & MREMAP_FIXED) || (new_addr == addr))
+ goto out;
+ }
diff --git a/sys-kernel/mips-prepatch-sources/mips-prepatch-sources-2.4.25_pre6.ebuild b/sys-kernel/mips-prepatch-sources/mips-prepatch-sources-2.4.25_pre6-r1.ebuild
index d323d3497f4e..8af2ecab9ee4 100644
--- a/sys-kernel/mips-prepatch-sources/mips-prepatch-sources-2.4.25_pre6.ebuild
+++ b/sys-kernel/mips-prepatch-sources/mips-prepatch-sources-2.4.25_pre6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-prepatch-sources/mips-prepatch-sources-2.4.25_pre6.ebuild,v 1.1 2004/02/10 06:57:29 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-prepatch-sources/mips-prepatch-sources-2.4.25_pre6-r1.ebuild,v 1.1 2004/02/18 21:56:26 kumba Exp $
# Version Data
@@ -58,14 +58,17 @@ src_unpack() {
epatch ${FILESDIR}/mipscvs-${OKV}-${CVSDATE}-makefile.patch
echo -e ""
+ # do_munmap fix (Possibly Exploitable)
+ epatch ${FILESDIR}/do_munmap-fix.patch
+
# Cobalt stuff
-# if [ "${PROFILE_ARCH}" = "cobalt" ]; then
+ if [ "${PROFILE_ARCH}" = "cobalt" ]; then
einfo ">>> Patching kernel for Cobalt support ..."
for x in ${WORKDIR}/cobalt-patches-24xx-${COBALTPATCHVER}/*.patch; do
epatch ${x}
done
cp ${WORKDIR}/cobalt-patches-24xx-${COBALTPATCHVER}/cobalt-patches.txt ${S}
-# fi
+ fi
kernel_universal_unpack
}