summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/pegasos-dev-sources/pegasos-dev-sources-2.6.6.ebuild')
-rw-r--r--sys-kernel/pegasos-dev-sources/pegasos-dev-sources-2.6.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-kernel/pegasos-dev-sources/pegasos-dev-sources-2.6.6.ebuild b/sys-kernel/pegasos-dev-sources/pegasos-dev-sources-2.6.6.ebuild
new file mode 100644
index 000000000000..480e8360ea00
--- /dev/null
+++ b/sys-kernel/pegasos-dev-sources/pegasos-dev-sources-2.6.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pegasos-dev-sources/pegasos-dev-sources-2.6.6.ebuild,v 1.1 2004/05/16 23:19:20 dholm Exp $
+
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+# Version of gentoo patchset
+GPV=5.1
+GPV_SRC="mirror://gentoo/pegpatches-${KV_MAJOR}.${KV_MINOR}-${GPV}.tar.bz2"
+
+KEYWORDS="ppc"
+
+UNIPATCH_LIST="${DISTDIR}/pegpatches-${KV_MAJOR}.${KV_MINOR}-${GPV}.tar.bz2"
+UNIPATCH_DOCS="${WORKDIR}/patches/pegpatches-${KV_MAJOR}.${KV_MINOR}-${GPV}/0000_README"
+
+DESCRIPTION="Full sources including the gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree on Pegasos computers"
+SRC_URI="${KERNEL_URI} ${GPV_SRC}"
+
+DEPEND="${DEPEND} >=dev-libs/ucl-1"
+
+pkg_postinst() {
+ postinst_sources
+
+ ewarn "IMPORTANT:"
+ ewarn "ptyfs support has now been dropped from devfs and as a"
+ ewarn "result you are now required to compile this support into"
+ ewarn "the kernel. You can do so by enabling the following option:"
+ ewarn " Device Drivers -> Character devices -> Legacy (BSD) PTY Support."
+ echo
+ ewarn "If you choose to use UCL/gcloop please ensure you compile gcloop"
+ ewarn "without -fstack-protector."
+ echo
+}