summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/com_err')
-rw-r--r--sys-libs/com_err/ChangeLog7
-rw-r--r--sys-libs/com_err/com_err-1.38.ebuild13
2 files changed, 13 insertions, 7 deletions
diff --git a/sys-libs/com_err/ChangeLog b/sys-libs/com_err/ChangeLog
index 25420cc5204f..09c88609e287 100644
--- a/sys-libs/com_err/ChangeLog
+++ b/sys-libs/com_err/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/com_err
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/ChangeLog,v 1.21 2005/11/10 21:22:09 flameeyes Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/ChangeLog,v 1.22 2006/01/06 23:34:22 flameeyes Exp $
+
+ 06 Jan 2006; Diego Pettenò <flameeyes@gentoo.org> com_err-1.38.ebuild:
+ Replace an userland check by $CHOST check; added comment with reasons.
10 Nov 2005; Diego Pettenò <flameeyes@gentoo.org> com_err-1.38.ebuild:
Move exporting of vars in src_compile() and src_install() to work around
diff --git a/sys-libs/com_err/com_err-1.38.ebuild b/sys-libs/com_err/com_err-1.38.ebuild
index 93125668a5e0..87e1b2ed5adb 100644
--- a/sys-libs/com_err/com_err-1.38.ebuild
+++ b/sys-libs/com_err/com_err-1.38.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/com_err-1.38.ebuild,v 1.16 2005/11/10 21:22:09 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/com_err-1.38.ebuild,v 1.17 2006/01/06 23:34:22 flameeyes Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -29,11 +29,14 @@ src_compile() {
export CC=$(tc-getCC)
export STRIP=/bin/true
+ # We want to use the "bsd" libraries while building on Darwin, but while
+ # building on other Gentoo/*BSD we prefer elf-naming scheme.
local libtype
- case ${USERLAND} in
- Darwin) libtype=bsd;;
- *) libtype=elf;;
+ case ${CHOST} in
+ *-darwin*) libtype=bsd;;
+ *) libtype=elf;;
esac
+
mkdir -p lib/{blkid,e2p,et,ext2fs,ss,uuid}/{checker,elfshared,pic,profiled} #102412
econf \
--enable-${libtype}-shlibs \