summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.3.5.20050421.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.3.5.ebuild4
3 files changed, 8 insertions, 8 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index b9671602f888..42d432abbf8a 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.45 2005/05/05 12:28:53 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.46 2005/05/16 03:03:53 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -536,7 +536,7 @@ toolchain-glibc_pkg_postinst() {
ln -s ../usr/share/zoneinfo/Factory ${ROOT}/etc/localtime
fi
- if [ -x "${ROOT}/usr/sbin/iconvconfig" ] ; then
+ if ! is_crosscompile && [ -x "${ROOT}/usr/sbin/iconvconfig" ] ; then
# Generate fastloading iconv module configuration file.
${ROOT}/usr/sbin/iconvconfig --prefix=${ROOT}
fi
@@ -547,7 +547,7 @@ toolchain-glibc_pkg_postinst() {
fi
# Reload init ...
- if [ "${ROOT}" = "/" ] ; then
+ if ! is_crosscompile && [ "${ROOT}" = "/" ] ; then
/sbin/init U &> /dev/null
fi
diff --git a/sys-libs/glibc/glibc-2.3.5.20050421.ebuild b/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
index 179d5ddc773d..4b5ebf4e6e15 100644
--- a/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050421.ebuild,v 1.7 2005/05/05 12:28:53 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050421.ebuild,v 1.8 2005/05/16 03:03:53 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -544,7 +544,7 @@ toolchain-glibc_pkg_postinst() {
ln -s ../usr/share/zoneinfo/Factory ${ROOT}/etc/localtime
fi
- if [ -x "${ROOT}/usr/sbin/iconvconfig" ] ; then
+ if ! is_crosscompile && [ -x "${ROOT}/usr/sbin/iconvconfig" ] ; then
# Generate fastloading iconv module configuration file.
${ROOT}/usr/sbin/iconvconfig --prefix=${ROOT}
fi
@@ -555,7 +555,7 @@ toolchain-glibc_pkg_postinst() {
fi
# Reload init ...
- if [ "${ROOT}" = "/" ] ; then
+ if ! is_crosscompile && [ "${ROOT}" = "/" ] ; then
/sbin/init U &> /dev/null
fi
diff --git a/sys-libs/glibc/glibc-2.3.5.ebuild b/sys-libs/glibc/glibc-2.3.5.ebuild
index 4e3d5be1de14..99eff0014350 100644
--- a/sys-libs/glibc/glibc-2.3.5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.13 2005/05/03 05:12:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.14 2005/05/16 03:03:53 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -537,7 +537,7 @@ toolchain-glibc_pkg_postinst() {
ln -s ../usr/share/zoneinfo/Factory ${ROOT}/etc/localtime
fi
- if [ -x "${ROOT}/usr/sbin/iconvconfig" ] ; then
+ if ! is_crosscompile && [ -x "${ROOT}/usr/sbin/iconvconfig" ] ; then
# Generate fastloading iconv module configuration file.
${ROOT}/usr/sbin/iconvconfig --prefix=${ROOT}
fi