summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/readline')
-rw-r--r--sys-libs/readline/ChangeLog7
-rw-r--r--sys-libs/readline/files/readline-5.1-rlfe-uclibc.patch64
2 files changed, 67 insertions, 4 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index fd8d1789e386..79ee32145c4d 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/readline
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.60 2006/02/04 20:06:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.61 2006/02/09 03:16:50 vapier Exp $
+
+ 09 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+ files/readline-5.1-rlfe-uclibc.patch:
+ Make sys/stropts.h a proper configure check/include and pull in more headers
+ to silence warnings #117060 by Benigno B. Junior.
*readline-5.1_p2 (04 Feb 2006)
diff --git a/sys-libs/readline/files/readline-5.1-rlfe-uclibc.patch b/sys-libs/readline/files/readline-5.1-rlfe-uclibc.patch
index fbb9e039128b..b60796f37bb1 100644
--- a/sys-libs/readline/files/readline-5.1-rlfe-uclibc.patch
+++ b/sys-libs/readline/files/readline-5.1-rlfe-uclibc.patch
@@ -1,11 +1,69 @@
---- examples/rlfe/pty.c.orig 2005-12-24 16:49:08 +0000
-+++ examples/rlfe/pty.c 2005-12-24 16:49:14 +0000
+--- examples/rlfe/pty.c
++++ examples/rlfe/pty.c
+@@ -23,6 +23,7 @@
+
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <unistd.h>
+ #include <fcntl.h>
+ #include <signal.h>
+
@@ -34,7 +34,7 @@
#endif
/* for solaris 2.1, Unixware (SVR4.2) and possibly others */
-#ifdef HAVE_SVR4_PTYS
-+#if defined(HAVE_SVR4_PTYS) && !defined(__UCLIBC__)
++#if defined(HAVE_SYS_STROPTS_H)
# include <sys/stropts.h>
#endif
+--- examples/rlfe/rlfe.c
++++ examples/rlfe/rlfe.c
+@@ -73,6 +73,9 @@
+ #include <termios.h>
+
+ #include "config.h"
++#include "extern.h"
++
++#include <sys/wait.h>
+
+ #ifdef READLINE_LIBRARY
+ # include "readline.h"
+--- configure
++++ configure
+@@ -4956,7 +4956,7 @@
+
+
+
+-for ac_header in sys/pte.h sys/stream.h sys/select.h sys/file.h
++for ac_header in sys/pte.h sys/stream.h sys/select.h sys/file.h sys/stropts.h sys/wait.h
+ do
+ as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ if eval "test \"\${$as_ac_Header+set}\" = set"; then
+
+--- configure.in
++++ configure.in
+@@ -148,7 +148,7 @@
+
+ AC_CHECK_HEADERS(fcntl.h unistd.h stdlib.h varargs.h stdarg.h string.h strings.h \
+ limits.h locale.h pwd.h memory.h termcap.h termios.h termio.h)
+-AC_CHECK_HEADERS(sys/pte.h sys/stream.h sys/select.h sys/file.h)
++AC_CHECK_HEADERS(sys/pte.h sys/stream.h sys/select.h sys/file.h sys/stropts.h sys/wait.h)
+
+ AC_CHECK_HEADERS(sys/ptem.h,,,
+ [[
+--- config.h.in
++++ config.h.in
+@@ -141,6 +141,12 @@
+ /* Define if you have the <sys/file.h> header file. */
+ #undef HAVE_SYS_FILE_H
+
++/* Define if you have the <sys/stropts.h> header file. */
++#undef HAVE_SYS_STROPTS_H
++
++/* Define if you have the <sys/wait.h> header file. */
++#undef HAVE_SYS_WAIT_H
++
+ /* Define if you have the <sys/ndir.h> header file. */
+ #undef HAVE_SYS_NDIR_H
+