summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog6
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r12.ebuild18
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r3.ebuild17
3 files changed, 11 insertions, 30 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index beca40b0b958..0e52285ed1bd 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.603 2009/01/14 11:21:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.604 2009/01/26 18:41:34 vapier Exp $
+
+ 26 Jan 2009; Mike Frysinger <vapier@gentoo.org> glibc-2.3.2-r12.ebuild,
+ glibc-2.3.5-r3.ebuild:
+ Drop USE=pic usage.
14 Jan 2009; Mike Frysinger <vapier@gentoo.org>
glibc-2.8_p20080602-r1.ebuild:
diff --git a/sys-libs/glibc/glibc-2.3.2-r12.ebuild b/sys-libs/glibc/glibc-2.3.2-r12.ebuild
index 36ed9cb7b968..7c27fe52f738 100644
--- a/sys-libs/glibc/glibc-2.3.2-r12.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r12.ebuild,v 1.24 2008/06/01 02:34:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r12.ebuild,v 1.25 2009/01/26 18:41:34 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -40,7 +40,7 @@ LICENSE="LGPL-2"
&& SLOT="${CTARGET}-2.2" \
|| SLOT="2.2"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc s390 sh sparc x86"
-IUSE="build nls nptl pic userlocales"
+IUSE="build nls nptl userlocales"
RESTRICT="strip" # we'll handle stripping ourself #46186
# We need new cleanup attribute support from gcc for NPTL among things ...
@@ -671,18 +671,6 @@ EOF
# This is our new config file for building locales
doins ${FILESDIR}/locales.build
- if use pic
- then
- find ${S}/${buildtarget}/ -name "soinit.os" -exec cp {} ${D}/lib/soinit.o \;
- find ${S}/${buildtarget}/ -name "sofini.os" -exec cp {} ${D}/lib/sofini.o \;
- find ${S}/${buildtarget}/ -name "*_pic.a" -exec cp {} ${D}/lib \;
- find ${S}/${buildtarget}/ -name "*.map" -exec cp {} ${D}/lib \;
- for i in ${D}/lib/*.map
- do
- mv ${i} ${i%.map}_pic.map
- done
- fi
-
# Is this next line actually needed or does the makefile get it right?
# It previously has 0755 perms which was killing things.
fperms 4755 /usr/lib/misc/pt_chown
diff --git a/sys-libs/glibc/glibc-2.3.5-r3.ebuild b/sys-libs/glibc/glibc-2.3.5-r3.ebuild
index 256580ea0884..56c6d35ddb0a 100644
--- a/sys-libs/glibc/glibc-2.3.5-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r3.ebuild,v 1.34 2008/09/05 20:23:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r3.ebuild,v 1.35 2009/01/26 18:41:34 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -48,7 +48,7 @@ DESCRIPTION="GNU libc6 (also called glibc2) C library"
HOMEPAGE="http://www.gnu.org/software/libc/libc.html"
LICENSE="LGPL-2"
-IUSE="nls pic build nptl nptlonly erandom hardened userlocales multilib selinux glibc-compat20 glibc-omitfp linuxthreads-tls profile"
+IUSE="nls build nptl nptlonly erandom hardened userlocales multilib selinux glibc-compat20 glibc-omitfp linuxthreads-tls profile"
export CBUILD=${CBUILD:-${CHOST}}
export CTARGET=${CTARGET:-${CHOST}}
@@ -372,17 +372,6 @@ toolchain-glibc_src_install() {
rm -rf ${D}/nptl
fi
- if use pic && [[ $(tc-arch) != "amd64" ]] ; then
- find ${S}/${buildtarget}/ -name "soinit.os" -exec cp {} ${D}$(alt_libdir)/soinit.o \;
- find ${S}/${buildtarget}/ -name "sofini.os" -exec cp {} ${D}$(alt_libdir)/sofini.o \;
- find ${S}/${buildtarget}/ -name "*_pic.a" -exec cp {} ${D}$(alt_libdir) \;
- find ${S}/${buildtarget}/ -name "*.map" -exec cp {} ${D}$(alt_libdir) \;
-
- for i in ${D}$(alt_libdir)/*.map; do
- mv ${i} ${i%.map}_pic.map
- done
- fi
-
# We'll take care of the cache ourselves
rm -f ${D}/etc/ld.so.cache