summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache/mod_caucho/mod_caucho-3.1.0.ebuild')
-rw-r--r--www-apache/mod_caucho/mod_caucho-3.1.0.ebuild45
1 files changed, 19 insertions, 26 deletions
diff --git a/www-apache/mod_caucho/mod_caucho-3.1.0.ebuild b/www-apache/mod_caucho/mod_caucho-3.1.0.ebuild
index 3ab656889868..f8a935c2ccd1 100644
--- a/www-apache/mod_caucho/mod_caucho-3.1.0.ebuild
+++ b/www-apache/mod_caucho/mod_caucho-3.1.0.ebuild
@@ -1,17 +1,22 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.1.0.ebuild,v 1.1 2006/12/26 01:50:59 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.1.0.ebuild,v 1.2 2007/01/15 15:54:22 chtekk Exp $
-inherit apache-module autotools
+inherit eutils apache-module autotools
-DESCRIPTION="mod_caucho connects Resin and Apache2"
-HOMEPAGE="http://www.caucho.com"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="mod_caucho connects Resin and Apache2."
+HOMEPAGE="http://www.caucho.com/"
SRC_URI="http://www.caucho.com/download/resin-${PV}-src.tar.gz"
LICENSE="GPL-2"
-
-KEYWORDS="~amd64 ~x86"
-IUSE=""
SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/resin-${PV}"
# See apache-module.eclass for more information.
APACHE2_MOD_CONF="88_${PN}"
@@ -19,39 +24,27 @@ APACHE2_MOD_DEFINE="CAUCHO"
need_apache2
-RDEPEND="${RDEPEND}"
-
-S="${WORKDIR}/resin-${PV}"
-
src_unpack() {
-
- unpack "${A}"
+ unpack ${A}
+ cd "${S}"
epatch "${FILESDIR}/${P}-gentoo.patch"
-
- cd "${S}"
eautoreconf
-
chmod 755 ./configure
-
}
src_compile() {
-
econf --with-apxs=${APXS2} || die "econf failed"
emake -j1 -C "${S}/modules/c/src/common/" || die "emake failed"
emake -j1 -C "${S}/modules/c/src/apache2/" || die "emake failed"
-
}
src_install() {
-
cd "${S}/modules/c/src/apache2"
- make DESTDIR="${D}" install || die "install failed"
-
- insinto ${APACHE2_MODULES_CONFDIR}
- doins ${FILESDIR}/${APACHE2_MOD_CONF}.conf || \
- die "internal ebuild error: '${FILESDIR}/${APACHE2_MOD_CONF}.conf' not found."
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ insinto "${APACHE2_MODULES_CONFDIR}"
+ doins "${FILESDIR}/${APACHE2_MOD_CONF}.conf" \
+ || die "internal ebuild error: '${FILESDIR}/${APACHE2_MOD_CONF}.conf' not found."
}