summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache/mod_watch')
-rw-r--r--www-apache/mod_watch/ChangeLog8
-rw-r--r--www-apache/mod_watch/files/77_mod_watch.conf59
-rw-r--r--www-apache/mod_watch/metadata.xml3
-rw-r--r--www-apache/mod_watch/mod_watch-4.03-r2.ebuild8
-rw-r--r--www-apache/mod_watch/mod_watch-4.03-r3.ebuild8
5 files changed, 43 insertions, 43 deletions
diff --git a/www-apache/mod_watch/ChangeLog b/www-apache/mod_watch/ChangeLog
index cb919b0999ab..213c4231204c 100644
--- a/www-apache/mod_watch/ChangeLog
+++ b/www-apache/mod_watch/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apache/mod_watch
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_watch/ChangeLog,v 1.4 2007/11/25 15:16:57 hollow Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_watch/ChangeLog,v 1.5 2008/01/29 18:19:58 hollow Exp $
+
+ 29 Jan 2008; Benedikt Böhm <hollow@gentoo.org> files/77_mod_watch.conf,
+ metadata.xml, mod_watch-4.03-r2.ebuild, mod_watch-4.03-r3.ebuild:
+ fix depend.apache usage wrt #208033; update metadata; cleanup
*mod_watch-4.03-r3 (25 Nov 2007)
diff --git a/www-apache/mod_watch/files/77_mod_watch.conf b/www-apache/mod_watch/files/77_mod_watch.conf
index 9d438ab2b410..b35f5b86f726 100644
--- a/www-apache/mod_watch/files/77_mod_watch.conf
+++ b/www-apache/mod_watch/files/77_mod_watch.conf
@@ -1,33 +1,32 @@
<IfDefine WATCH>
- <IfModule !mod_watch.c>
- LoadModule watch_module modules/mod_watch.so
- </IfModule>
-</IfDefine>
-<IfModule mod_watch.c>
- # Allows the URL used to query virtual host data:
- #
- # http://www.snert.com/watch-info
- #
- <Location /watch-info>
- SetHandler watch-info
- </Location>
+LoadModule watch_module modules/mod_watch.so
+
+# Allows the URL used to query virtual host data:
+#
+# http://www.snert.com/watch-info
+#
+<Location /watch-info>
+ SetHandler watch-info
+</Location>
- # Allows the URL used to query file owner and web
- # server data:
- #
- # http://www.snert.com/~achowe/watch-info
- # http://www.snert.com/~SERVER/watch-info
- #
- <Location /~*/watch-info>
- SetHandler watch-info
- </Location>
+# Allows the URL used to query file owner and web
+# server data:
+#
+# http://www.snert.com/~achowe/watch-info
+# http://www.snert.com/~SERVER/watch-info
+#
+<Location /~*/watch-info>
+ SetHandler watch-info
+</Location>
+
+# Intended for debugging and analysis of shared memory
+# hash table and weenie files:
+#
+# http://www.snert.com/watch-table
+#
+<Location /watch-table>
+ SetHandler watch-table
+</Location>
+</IfDefine>
- # Intended for debugging and analysis of shared memory
- # hash table and weenie files:
- #
- # http://www.snert.com/watch-table
- #
- <Location /watch-table>
- SetHandler watch-table
- </Location>
-</IfModule>
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_watch/metadata.xml b/www-apache/mod_watch/metadata.xml
index a1f5ceff2352..64a719ea1bfd 100644
--- a/www-apache/mod_watch/metadata.xml
+++ b/www-apache/mod_watch/metadata.xml
@@ -2,7 +2,4 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>apache</herd>
- <maintainer>
- <email>apache-bugs@gentoo.org</email>
- </maintainer>
</pkgmetadata>
diff --git a/www-apache/mod_watch/mod_watch-4.03-r2.ebuild b/www-apache/mod_watch/mod_watch-4.03-r2.ebuild
index d79e00a7f6f5..75ba4282fcb6 100644
--- a/www-apache/mod_watch/mod_watch-4.03-r2.ebuild
+++ b/www-apache/mod_watch/mod_watch-4.03-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_watch/mod_watch-4.03-r2.ebuild,v 1.2 2007/11/25 13:37:21 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_watch/mod_watch-4.03-r2.ebuild,v 1.3 2008/01/29 18:19:58 hollow Exp $
inherit apache-module
@@ -27,8 +27,8 @@ need_apache2
src_compile() {
sed -i \
- -e "s:APXS=\\(.*\\):APXS=${APXS2} # \\1:" \
- -e "s:APACHECTL=\\(.*\\):APACHECTL=${APACHECTL2} # \\1:" \
+ -e "s:APXS=\\(.*\\):APXS=${APXS} # \\1:" \
+ -e "s:APACHECTL=\\(.*\\):APACHECTL=${APACHECTL} # \\1:" \
Makefile.dso || die "Path fixing failed"
sed -i -e "s:/usr/local/sbin:/usr/sbin:" \
diff --git a/www-apache/mod_watch/mod_watch-4.03-r3.ebuild b/www-apache/mod_watch/mod_watch-4.03-r3.ebuild
index 29e164beb750..8d61d8045d3d 100644
--- a/www-apache/mod_watch/mod_watch-4.03-r3.ebuild
+++ b/www-apache/mod_watch/mod_watch-4.03-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_watch/mod_watch-4.03-r3.ebuild,v 1.1 2007/11/25 15:16:57 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_watch/mod_watch-4.03-r3.ebuild,v 1.2 2008/01/29 18:19:58 hollow Exp $
inherit apache-module eutils
@@ -33,8 +33,8 @@ src_unpack() {
src_compile() {
sed -i \
- -e "s:APXS=\\(.*\\):APXS=${APXS2} # \\1:" \
- -e "s:APACHECTL=\\(.*\\):APACHECTL=${APACHECTL2} # \\1:" \
+ -e "s:APXS=\\(.*\\):APXS=${APXS} # \\1:" \
+ -e "s:APACHECTL=\\(.*\\):APACHECTL=${APACHECTL} # \\1:" \
Makefile.dso || die "Path fixing failed"
sed -i -e "s:/usr/local/sbin:/usr/sbin:" \