summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/blohg/blohg-0.10.1.ebuild')
-rw-r--r--www-apps/blohg/blohg-0.10.1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/www-apps/blohg/blohg-0.10.1.ebuild b/www-apps/blohg/blohg-0.10.1.ebuild
index 934da8eef455..7e69747e517a 100644
--- a/www-apps/blohg/blohg-0.10.1.ebuild
+++ b/www-apps/blohg/blohg-0.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/blohg/blohg-0.10.1.ebuild,v 1.2 2012/07/06 22:24:13 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/blohg/blohg-0.10.1.ebuild,v 1.3 2012/08/04 19:58:28 rafaelmartins Exp $
EAPI="3"
@@ -16,7 +16,7 @@ if [[ ${PV} = *9999* ]]; then
EHG_REVISION="default"
fi
-inherit distutils ${HG_ECLASS}
+inherit eutils distutils ${HG_ECLASS}
DESCRIPTION="A Mercurial-based blogging engine."
HOMEPAGE="http://blohg.org/ http://pypi.python.org/pypi/blohg"
@@ -48,6 +48,11 @@ DEPEND="${CDEPEND}
RDEPEND="${CDEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}/${PV}_fix-tests.patch"
+ distutils_src_prepare
+}
+
src_compile() {
distutils_src_compile