summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/rt')
-rw-r--r--www-apps/rt/ChangeLog9
-rw-r--r--www-apps/rt/files/postinstall-en.txt (renamed from www-apps/rt/files/3.4.5/postinstall-en.txt)0
-rw-r--r--www-apps/rt/files/reconfig (renamed from www-apps/rt/files/3.4.5/reconfig)15
-rw-r--r--www-apps/rt/files/rt.conf.d4
-rw-r--r--www-apps/rt/files/rt_apache2.conf25
-rw-r--r--www-apps/rt/files/rt_apache2_fcgi.conf73
-rw-r--r--www-apps/rt/rt-3.6.3.ebuild7
-rw-r--r--www-apps/rt/rt-3.6.6.ebuild9
8 files changed, 81 insertions, 61 deletions
diff --git a/www-apps/rt/ChangeLog b/www-apps/rt/ChangeLog
index 5f32c0016ad3..16eb8b5b3ae9 100644
--- a/www-apps/rt/ChangeLog
+++ b/www-apps/rt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/rt
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/ChangeLog,v 1.55 2008/03/07 14:37:28 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/ChangeLog,v 1.56 2008/04/03 09:57:12 hollow Exp $
+
+ 03 Apr 2008; Benedikt Böhm <hollow@gentoo.org>
+ -files/3.4.5/postinstall-en.txt, -files/3.4.5/reconfig,
+ +files/postinstall-en.txt, +files/reconfig, files/rt.conf.d,
+ files/rt_apache2_fcgi.conf, files/rt_apache2.conf, rt-3.6.3.ebuild,
+ rt-3.6.6.ebuild:
+ fix #213235, #215871; cleanup
*rt-3.6.6 (07 Mar 2008)
diff --git a/www-apps/rt/files/3.4.5/postinstall-en.txt b/www-apps/rt/files/postinstall-en.txt
index c77c0a11e922..c77c0a11e922 100644
--- a/www-apps/rt/files/3.4.5/postinstall-en.txt
+++ b/www-apps/rt/files/postinstall-en.txt
diff --git a/www-apps/rt/files/3.4.5/reconfig b/www-apps/rt/files/reconfig
index 3c0153013985..e84018c3f9b8 100644
--- a/www-apps/rt/files/3.4.5/reconfig
+++ b/www-apps/rt/files/reconfig
@@ -14,8 +14,19 @@ if [ $1 = "install" ]; then
sed -e "s|${MY_HOSTROOTDIR}/${PF}|${VHOST_ROOT}/${PF}|g
s|${MY_HTDOCSDIR}|${MY_INSTALLDIR}|g" -i bin/* lib/RT.pm sbin/* etc/RT_Config.pm || die
- sed -e "s|RT_DIR|${VHOST_ROOT}/${PF}|g
- s|HTDOCS|${MY_INSTALLDIR}|g" -i ${VHOST_ROOT}/${PF}/etc/rt_apache* || die
+ if [[ -e ${VHOST_ROOT}/${PF}/etc/rt_apache2.conf ]]; then
+ sed -i \
+ -e "s|RT_DIR|${VHOST_ROOT}/${PF}|g"
+ -e "s|HTDOCS|${MY_INSTALLDIR}|g" \
+ ${VHOST_ROOT}/${PF}/etc/rt_apache2.conf
+ fi
+
+ if [[ -e ${VHOST_ROOT}/${PF}/etc/rt_apache2_fcgi.conf ]]; then
+ sed -i \
+ -e "s|RT_DIR|${VHOST_ROOT}/${PF}|g"
+ -e "s|HTDOCS|${MY_INSTALLDIR}|g" \
+ ${VHOST_ROOT}/${PF}/etc/rt_apache2_fcgi.conf
+ fi
# check for upgrades
cd ${VHOST_ROOT}/${PF}/upgrade
diff --git a/www-apps/rt/files/rt.conf.d b/www-apps/rt/files/rt.conf.d
index 5fa292d2aefb..294ac2a0bd46 100644
--- a/www-apps/rt/files/rt.conf.d
+++ b/www-apps/rt/files/rt.conf.d
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/files/rt.conf.d,v 1.1 2006/01/26 21:10:33 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/files/rt.conf.d,v 1.2 2008/04/03 09:57:12 hollow Exp $
# Config file for /etc/init.d/rt
@@ -8,7 +8,7 @@ RTUSER=rt
RTGROUP=lighttpd
# set RTPATH to rt's root
-RTPATH=/var/www/localhost/rt-3.4.5
+RTPATH=/var/www/localhost/@@PF@@
FCGI_SOCKET_PATH=${RTPATH}/var/appSocket
PIDFILE=${RTPATH}/var/pid
diff --git a/www-apps/rt/files/rt_apache2.conf b/www-apps/rt/files/rt_apache2.conf
index 896f642c55af..363c34f45bf7 100644
--- a/www-apps/rt/files/rt_apache2.conf
+++ b/www-apps/rt/files/rt_apache2.conf
@@ -1,18 +1,18 @@
<IfDefine PERL>
- <VirtualHost MY_RT_DOMAIN:80>
- ServerName MY_RT_DOMAIN
-
- DocumentRoot HTDOCS
+<VirtualHost MY_RT_DOMAIN:80>
+ ServerName MY_RT_DOMAIN
+ DocumentRoot HTDOCS
ServerAdmin YOUR_EMAIL_HERE
- AddDefaultCharset UTF-8
+ AddDefaultCharset UTF-8
+
<IfDefine USERDIR>
- UserDir disabled
+ UserDir disabled
</IfDefine>
-
- PerlModule Apache::DBI
- PerlRequire RT_DIR/bin/webmux.pl
-
+
+ PerlModule Apache::DBI
+ PerlRequire RT_DIR/bin/webmux.pl
+
<Location />
SetHandler perl-script
PerlHandler RT::Mason
@@ -25,6 +25,7 @@
Order allow,deny
Allow from all
</Directory>
-
- </VirtualHost>
+</VirtualHost>
</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apps/rt/files/rt_apache2_fcgi.conf b/www-apps/rt/files/rt_apache2_fcgi.conf
index aa6ccdc9a04e..2a93f8cea2b7 100644
--- a/www-apps/rt/files/rt_apache2_fcgi.conf
+++ b/www-apps/rt/files/rt_apache2_fcgi.conf
@@ -1,39 +1,38 @@
<IfDefine FASTCGI>
-
- # Tell FastCGI to put its temporary files somewhere sane.
- FastCgiIpcDir /tmp
-
- # Tell FastCGI that it should use apache's "suexec" binary to call any FastCGI script.
- # This is a GLOBAL setting
- FastCgiWrapper /usr/sbin/suexec2
-
- # Apache 1.3 discards the user and group parameters on the FastCgiServer line.
- # Apache 2.0 requires them.
- FastCgiServer RT_DIR/bin/mason_handler.fcgi -idle-timeout 120 -user rt -group rt -processes 4
-
-
- <VirtualHost MY_RT_DOMAIN:80>
- ServerName MY_RT_DOMAIN
-
- DocumentRoot HTDOCS
- ServerAdmin YOUR_EMAIL_HERE
-
- AddDefaultCharset UTF-8
- <IfDefine USERDIR>
- UserDir disabled
- </IfDefine>
-
- # Set the rt user and group as the executing user for this virtual host
- SuexecUserGroup rt rt
- AddHandler fastcgi-script fcgi
- ScriptAlias / RT_DIR/bin/mason_handler.fcgi/
-
- <Directory "HTDOCS">
- Options Indexes FollowSymLinks
- AllowOverride None
- Order allow,deny
- Allow from all
- </Directory>
-
- </VirtualHost>
+# Tell FastCGI to put its temporary files somewhere sane.
+FastCgiIpcDir /tmp
+
+# Tell FastCGI that it should use apache's "suexec" binary to call any FastCGI script.
+# This is a GLOBAL setting
+FastCgiWrapper /usr/sbin/suexec2
+
+# Apache 1.3 discards the user and group parameters on the FastCgiServer line.
+# Apache 2.0 requires them.
+FastCgiServer RT_DIR/bin/mason_handler.fcgi -idle-timeout 120 -user rt -group rt -processes 4
+
+<VirtualHost MY_RT_DOMAIN:80>
+ ServerName MY_RT_DOMAIN
+ DocumentRoot HTDOCS
+ ServerAdmin YOUR_EMAIL_HERE
+
+ AddDefaultCharset UTF-8
+
+ <IfDefine USERDIR>
+ UserDir disabled
+ </IfDefine>
+
+ # Set the rt user and group as the executing user for this virtual host
+ SuexecUserGroup rt rt
+ AddHandler fastcgi-script fcgi
+ ScriptAlias / RT_DIR/bin/mason_handler.fcgi/
+
+ <Directory "HTDOCS">
+ Options Indexes FollowSymLinks
+ AllowOverride None
+ Order allow,deny
+ Allow from all
+ </Directory>
+</VirtualHost>
</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apps/rt/rt-3.6.3.ebuild b/www-apps/rt/rt-3.6.3.ebuild
index 0600443f12fa..eaa5cb010c18 100644
--- a/www-apps/rt/rt-3.6.3.ebuild
+++ b/www-apps/rt/rt-3.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.6.3.ebuild,v 1.9 2008/02/05 15:04:28 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.6.3.ebuild,v 1.10 2008/04/03 09:57:12 hollow Exp $
inherit webapp eutils depend.apache
@@ -231,12 +231,13 @@ src_install() {
if useq lighttpd; then
newinitd ${FILESDIR}/${PN}.init.d ${PN}
newconfd ${FILESDIR}/${PN}.conf.d ${PN}
+ dosed "s/@@PF@@/${PF}/g" /etc/conf.d/${PN}
else
local CONF="rt_apache2_fcgi.conf rt_apache2.conf"
cd ${FILESDIR} && cp ${CONF} ${D}/${MY_HOSTROOTDIR}/${PF}/etc
fi
- webapp_postinst_txt en ${FILESDIR}/3.4.5/postinstall-en.txt
- webapp_hook_script ${FILESDIR}/3.4.5/reconfig
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_hook_script ${FILESDIR}/reconfig
webapp_serverowned ${MY_HOSTROOTDIR}/${PF}/var
webapp_src_install
diff --git a/www-apps/rt/rt-3.6.6.ebuild b/www-apps/rt/rt-3.6.6.ebuild
index 30dad35a791b..e07752a19fa3 100644
--- a/www-apps/rt/rt-3.6.6.ebuild
+++ b/www-apps/rt/rt-3.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.6.6.ebuild,v 1.1 2008/03/07 14:37:28 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.6.6.ebuild,v 1.2 2008/04/03 09:57:12 hollow Exp $
inherit webapp eutils depend.apache confutils
@@ -206,7 +206,7 @@ src_install() {
rm -f "${D}"/${MY_HOSTROOTDIR}/${PF}/etc/RT_SiteConfig.pm
# fix paths
- find "${D}" -type f -print0 | xargs -0 dosed
+ find "${D}" -type f -print0 | xargs -0 sed -i -e "s:${D}::g"
# copy upgrade files
insinto "${MY_HOSTROOTDIR}/${PF}"
@@ -215,14 +215,15 @@ src_install() {
if use lighttpd; then
newinitd "${FILESDIR}"/${PN}.init.d ${PN}
newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+ dosed "s/@@PF@@/${PF}/g" /etc/conf.d/${PN}
else
doins "${FILESDIR}"/{rt_apache2_fcgi.conf,rt_apache2.conf}
fi
webapp_serverowned "${MY_HOSTROOTDIR}"/${PF}/var
- webapp_postinst_txt en "${FILESDIR}"/3.4.5/postinstall-en.txt
- webapp_hook_script "${FILESDIR}"/3.4.5/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_hook_script "${FILESDIR}"/reconfig
webapp_src_install
}