summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client')
-rw-r--r--www-client/lynx/ChangeLog8
-rw-r--r--www-client/lynx/files/lynx-2.8.6-CVE-2008-4690.patch44
-rw-r--r--www-client/lynx/files/lynx-2.8.8_pre9-zlib.patch452
-rw-r--r--www-client/lynx/lynx-2.8.8_pre10.ebuild116
-rw-r--r--www-client/lynx/lynx-2.8.8_pre5.ebuild125
-rw-r--r--www-client/lynx/lynx-2.8.8_pre9.ebuild117
6 files changed, 7 insertions, 855 deletions
diff --git a/www-client/lynx/ChangeLog b/www-client/lynx/ChangeLog
index 3786167a5dc6..9f77dc20192f 100644
--- a/www-client/lynx/ChangeLog
+++ b/www-client/lynx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/lynx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.113 2012/02/23 03:47:36 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.114 2012/02/23 03:51:26 radhermit Exp $
+
+ 23 Feb 2012; Tim Harder <radhermit@gentoo.org>
+ -files/lynx-2.8.6-CVE-2008-4690.patch, -lynx-2.8.8_pre5.ebuild,
+ -lynx-2.8.8_pre9.ebuild, -lynx-2.8.8_pre10.ebuild,
+ -files/lynx-2.8.8_pre9-zlib.patch:
+ Remove old.
*lynx-2.8.8_pre12 (23 Feb 2012)
diff --git a/www-client/lynx/files/lynx-2.8.6-CVE-2008-4690.patch b/www-client/lynx/files/lynx-2.8.6-CVE-2008-4690.patch
deleted file mode 100644
index da2647b49b53..000000000000
--- a/www-client/lynx/files/lynx-2.8.6-CVE-2008-4690.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-Index: lynx2-8-6/CHANGES
-===================================================================
---- lynx2-8-6.orig/CHANGES
-+++ lynx2-8-6/CHANGES
-@@ -1,6 +1,13 @@
- Changes since Lynx 2.8 release
- ===============================================================================
-
-+2008-10-26
-+* modify patch for CVE-2005-2929 to prompt user before executing command via
-+ a lynxcgi link even in advanced mode, as the actual URL may not be shown but
-+ hidden behind an HTTP redirect
-+* set TRUSTED_LYNXCGI:none in lynx.cfg to disable all lynxcgi URLs by default
-+ [CVE-2008-4690]
-+
- 2006-11-15 (2.8.6rel.4 diverges from 2.8.7dev.4)
- * limit files set via PERSONAL_EXTENSION_MAP and PERSONAL_MAILCAP to be found
- relative to the user's home directory. This change is less flexible than the
-Index: lynx2-8-6/lynx.cfg
-===================================================================
---- lynx2-8-6.orig/lynx.cfg
-+++ lynx2-8-6/lynx.cfg
-@@ -1026,7 +1026,7 @@ DEFAULT_INDEX_FILE:http://lynx.isc.org/
- # ====
- # Do not define this.
- #
--#TRUSTED_LYNXCGI:none
-+TRUSTED_LYNXCGI:none
-
-
- .h2 LYNXCGI_ENVIRONMENT
-Index: lynx2-8-6/src/LYCgi.c
-===================================================================
---- lynx2-8-6.orig/src/LYCgi.c
-+++ lynx2-8-6/src/LYCgi.c
-@@ -165,7 +165,7 @@ static BOOL can_exec_cgi(const char *lin
- if (!exec_ok(HTLoadedDocumentURL(), linktext, CGI_PATH)) {
- /* exec_ok gives out msg. */
- result = FALSE;
-- } else if (user_mode < ADVANCED_MODE) {
-+ } else {
- StrAllocCopy(command, linktext);
- if (non_empty(linkargs)) {
- HTSprintf(&command, " %s", linkargs);
diff --git a/www-client/lynx/files/lynx-2.8.8_pre9-zlib.patch b/www-client/lynx/files/lynx-2.8.8_pre9-zlib.patch
deleted file mode 100644
index b4b5bb60c30c..000000000000
--- a/www-client/lynx/files/lynx-2.8.8_pre9-zlib.patch
+++ /dev/null
@@ -1,452 +0,0 @@
---- a/src/GridText.c
-+++ b/src/GridText.c
-@@ -124,8 +124,8 @@
- const char *checked_radio = "(*)";
- const char *unchecked_radio = "( )";
-
--static BOOLEAN underline_on = OFF;
--static BOOLEAN bold_on = OFF;
-+static BOOLEAN underline_on = LOFF;
-+static BOOLEAN bold_on = LOFF;
-
- #ifdef USE_SOURCE_CACHE
- int LYCacheSource = SOURCE_CACHE_NONE;
-@@ -2406,7 +2406,7 @@
- /*
- * Bold the link after incrementing nlinks.
- */
-- LYhighlight(OFF, (nlinks - 1), target);
-+ LYhighlight(LOFF, (nlinks - 1), target);
-
- display_flag = TRUE;
-
-@@ -4018,27 +4018,27 @@
- if (ch == LY_UNDERLINE_START_CHAR) {
- line->data[line->size++] = LY_UNDERLINE_START_CHAR;
- line->data[line->size] = '\0';
-- underline_on = ON;
-+ underline_on = LON;
- if (!(dump_output_immediately && use_underscore))
- ctrl_chars_on_this_line++;
- return;
- } else if (ch == LY_UNDERLINE_END_CHAR) {
- line->data[line->size++] = LY_UNDERLINE_END_CHAR;
- line->data[line->size] = '\0';
-- underline_on = OFF;
-+ underline_on = LOFF;
- if (!(dump_output_immediately && use_underscore))
- ctrl_chars_on_this_line++;
- return;
- } else if (ch == LY_BOLD_START_CHAR) {
- line->data[line->size++] = LY_BOLD_START_CHAR;
- line->data[line->size] = '\0';
-- bold_on = ON;
-+ bold_on = LON;
- ctrl_chars_on_this_line++;
- return;
- } else if (ch == LY_BOLD_END_CHAR) {
- line->data[line->size++] = LY_BOLD_END_CHAR;
- line->data[line->size] = '\0';
-- bold_on = OFF;
-+ bold_on = LOFF;
- ctrl_chars_on_this_line++;
- return;
- } else if (ch == LY_SOFT_HYPHEN) {
---- a/src/LYCurses.c
-+++ b/src/LYCurses.c
-@@ -2928,7 +2928,7 @@
- int pending GCC_UNUSED)
- {
- #ifdef USE_COLOR_STYLE
-- LynxChangeStyle(flag == ON ? s_alink : s_a, ABS_OFF);
-+ LynxChangeStyle(flag == LON ? s_alink : s_a, ABS_OFF);
- #else
- if (flag) {
- lynx_stop_reverse();
---- a/src/LYLocal.c
-+++ b/src/LYLocal.c
-@@ -1597,7 +1597,7 @@
- if (nlinks > 0) {
- LYmove(links[cur].ly, 2);
- lynx_stop_reverse();
-- if (flag == ON) {
-+ if (flag == LON) {
- LYaddch('+');
- } else {
- LYaddch(' ');
-@@ -1630,7 +1630,7 @@
- s = t;
- while ((name = (char *) HTList_nextObject(s)) != NULL) {
- if (!strcmp(links[i].lname, name)) {
-- tagflag(ON, i);
-+ tagflag(LON, i);
- break;
- }
- }
---- a/src/LYMainLoop.c
-+++ b/src/LYMainLoop.c
-@@ -513,7 +513,7 @@
- && nextlink >= 0
- && nextlink < nlinks) {
- if (curdoc.link >= 0 && curdoc.link < nlinks) {
-- LYhighlight(OFF, curdoc.link, prev_target);
-+ LYhighlight(LOFF, curdoc.link, prev_target);
- result = TRUE;
- }
- curdoc.link = nextlink;
-@@ -548,7 +548,7 @@
- static void set_curdoc_link_by_mouse(int nextlink)
- {
- if (set_curdoc_link(nextlink)) {
-- LYhighlight(ON, nextlink, prev_target);
-+ LYhighlight(LON, nextlink, prev_target);
- LYmsec_delay(20);
- }
- }
-@@ -3574,7 +3574,7 @@
- newdoc.isHEAD = FALSE;
- newdoc.safe = FALSE;
- newdoc.internal_link = FALSE;
-- LYhighlight(OFF, curdoc.link, prev_target);
-+ LYhighlight(LOFF, curdoc.link, prev_target);
- #ifdef DIRED_SUPPORT
- if (lynx_edit_mode) {
- DIRED_UNCACHE_2;
-@@ -3834,7 +3834,7 @@
- int real_c)
- {
- if (curdoc.link < nlinks - 1) { /* next link */
-- LYhighlight(OFF, curdoc.link, prev_target);
-+ LYhighlight(LOFF, curdoc.link, prev_target);
- #ifdef FASTTAB
- /*
- * Move to different textarea if TAB in textarea.
-@@ -4475,7 +4475,7 @@
- found = TRUE;
- HTList_removeObject(tagged, tagname);
- FREE(tagname);
-- tagflag(OFF, curdoc.link);
-+ tagflag(LOFF, curdoc.link);
- break;
- }
- }
-@@ -4485,7 +4485,7 @@
- tagname = NULL;
- StrAllocCopy(tagname, links[curdoc.link].lname);
- HTList_addObject(tagged, tagname);
-- tagflag(ON, curdoc.link);
-+ tagflag(LON, curdoc.link);
- }
- }
- if (curdoc.link < nlinks - 1) {
-@@ -6510,10 +6510,10 @@
- * Highlight current link, unless it is an active text input field.
- */
- if (!curlink_is_editable) {
-- LYhighlight(ON, curdoc.link, prev_target);
-+ LYhighlight(LON, curdoc.link, prev_target);
- #ifndef INACTIVE_INPUT_STYLE_VH
- } else if (!textinput_activated) {
-- LYhighlight(ON, curdoc.link, prev_target);
-+ LYhighlight(LON, curdoc.link, prev_target);
- #endif
- }
- }
---- a/src/LYSearch.c
-+++ b/src/LYSearch.c
-@@ -336,7 +336,7 @@
- /*
- * Found in link, changed cur, we're done.
- */
-- LYhighlight(OFF, oldcur, prev_target);
-+ LYhighlight(LOFF, oldcur, prev_target);
- return (TRUE);
- }
- } else {
-@@ -349,7 +349,7 @@
- /*
- * Found in link, changed cur, we're done.
- */
-- LYhighlight(OFF, oldcur, prev_target);
-+ LYhighlight(LOFF, oldcur, prev_target);
- return (TRUE);
- }
-
-@@ -369,7 +369,7 @@
- */
- www_user_search((cur_doc->line + offset), cur_doc, prev_target, direction);
- if (cur_doc->link != oldcur) {
-- LYhighlight(OFF, oldcur, prev_target);
-+ LYhighlight(LOFF, oldcur, prev_target);
- return (TRUE);
- }
- return (BOOL) (www_search_result > 0);
---- a/src/LYUtils.c
-+++ b/src/LYUtils.c
-@@ -553,7 +553,7 @@
- * Start emphasis immediately if we are making the link
- * non-current. -FM
- */
-- if (flag != ON) {
-+ if (flag != LON) {
- LYstartTargetEmphasis();
- TargetEmphasisON = TRUE;
- LYaddstr(tmp);
-@@ -571,7 +571,7 @@
- * Start emphasis immediately if we are making the link
- * non-current. -FM
- */
-- if (flag != ON) {
-+ if (flag != LON) {
- LYstartTargetEmphasis();
- TargetEmphasisON = TRUE;
- LYaddstr(tmp);
-@@ -585,7 +585,7 @@
- * Start emphasis immediately if we are making the link
- * non-current. -FM
- */
-- if (flag != ON) {
-+ if (flag != LON) {
- LYstartTargetEmphasis();
- TargetEmphasisON = TRUE;
- LYaddstr(tmp);
-@@ -625,7 +625,7 @@
- * character of hightext if we are making the link
- * current. -FM
- */
-- if (flag == ON && data[(itmp + 1)] == '\0') {
-+ if (flag == LON && data[(itmp + 1)] == '\0') {
- LYstopTargetEmphasis();
- TargetEmphasisON = FALSE;
- LYGetYX(y, offset);
-@@ -645,7 +645,7 @@
- * character of hightext if we are making the link
- * current. -FM
- */
-- if (flag == ON && data[(itmp + 1)] == '\0') {
-+ if (flag == LON && data[(itmp + 1)] == '\0') {
- LYstopTargetEmphasis();
- TargetEmphasisON = FALSE;
- LYGetYX(y, offset);
-@@ -661,7 +661,7 @@
- * character of hightext if we are making the link
- * current. -FM
- */
-- if (flag == ON && data[(itmp + 1)] == '\0') {
-+ if (flag == LON && data[(itmp + 1)] == '\0') {
- LYstopTargetEmphasis();
- TargetEmphasisON = FALSE;
- LYGetYX(y, offset);
-@@ -684,7 +684,7 @@
- TargetEmphasisON = FALSE;
- }
- LYGetYX(y, offset);
-- if (offset < (hoffset + (flag == ON ? (hLen - 1) : hLen))
-+ if (offset < (hoffset + (flag == LON ? (hLen - 1) : hLen))
- /*
- * See if we have another hit that starts within the
- * hightext. -FM
-@@ -705,7 +705,7 @@
- */
- && (HitOffset + offset) <
- (hoffset +
-- (flag == ON ? (hLen - 1) : hLen))) {
-+ (flag == LON ? (hLen - 1) : hLen))) {
- /*
- * Set up the data and offset for the hit, and let the code
- * for within hightext hits handle it. -FM
-@@ -726,7 +726,7 @@
- * hightext, we are done. Otherwise, move there and start
- * restoring the emphasis. -FM
- */
-- if ((Offset - offset) <= (flag == ON ? (hLen - 1) : hLen)) {
-+ if ((Offset - offset) <= (flag == LON ? (hLen - 1) : hLen)) {
- data = SKIP_GLYPHS(utf_flag, data, Offset - offset);
- if (utf_flag) {
- LYrefresh();
-@@ -751,7 +751,7 @@
- * non-current, or we are making it current but this is not
- * the first or last character of the hightext. -FM
- */
-- if (flag != ON ||
-+ if (flag != LON ||
- (offset > hoffset && data[itmp + 1] != '\0')) {
- LYstartTargetEmphasis();
- TargetEmphasisON = TRUE;
-@@ -771,7 +771,7 @@
- * non-current, or we are making it current but this is not
- * the first or last character of the hightext. -FM
- */
-- if (flag != ON ||
-+ if (flag != LON ||
- (offset > hoffset && data[itmp + 1] != '\0')) {
- LYstartTargetEmphasis();
- TargetEmphasisON = TRUE;
-@@ -787,7 +787,7 @@
- * non-current, or we are making it current but this is not
- * the first or last character of the hightext. -FM
- */
-- if (flag != ON ||
-+ if (flag != LON ||
- (offset > hoffset && data[itmp + 1] != '\0')) {
- LYstartTargetEmphasis();
- TargetEmphasisON = TRUE;
-@@ -825,7 +825,7 @@
- * character of hightext if we are making the link
- * current. -FM
- */
-- if (flag == ON && data[(itmp + 1)] == '\0') {
-+ if (flag == LON && data[(itmp + 1)] == '\0') {
- LYstopTargetEmphasis();
- TargetEmphasisON = FALSE;
- LYGetYX(y, offset);
-@@ -845,7 +845,7 @@
- * character of hightext if we are making the link
- * current. -FM
- */
-- if (flag == ON && data[(itmp + 1)] == '\0') {
-+ if (flag == LON && data[(itmp + 1)] == '\0') {
- LYstopTargetEmphasis();
- TargetEmphasisON = FALSE;
- LYGetYX(y, offset);
-@@ -861,7 +861,7 @@
- * character of hightext if we are making the link
- * current. -FM
- */
-- if (flag == ON && data[(itmp + 1)] == '\0') {
-+ if (flag == LON && data[(itmp + 1)] == '\0') {
- LYstopTargetEmphasis();
- TargetEmphasisON = FALSE;
- LYGetYX(y, offset);
-@@ -884,7 +884,7 @@
- TargetEmphasisON = FALSE;
- }
- LYGetYX(y, offset);
-- if (offset < (hoffset + (flag == ON ? (hLen - 1) : hLen))
-+ if (offset < (hoffset + (flag == LON ? (hLen - 1) : hLen))
- /*
- * See if we have another hit that starts within the
- * hightext. -FM
-@@ -904,7 +904,7 @@
- * last character, we are done. -FM
- */
- && (HitOffset + offset) <
-- (hoffset + (flag == ON ? (hLen - 1) : hLen))) {
-+ (hoffset + (flag == LON ? (hLen - 1) : hLen))) {
- /*
- * If the target extends beyond our buffer, emphasize
- * everything in the hightext starting at this hit.
-@@ -945,7 +945,7 @@
- * last character of hightext if we are making
- * the link current. -FM
- */
-- if (flag == ON && data[(itmp + 1)] == '\0') {
-+ if (flag == LON && data[(itmp + 1)] == '\0') {
- LYstopTargetEmphasis();
- TargetEmphasisON = FALSE;
- LYGetYX(y, offset);
-@@ -965,7 +965,7 @@
- * last character of hightext if we are making
- * the link current. -FM
- */
-- if (flag == ON && data[(itmp + 1)] == '\0') {
-+ if (flag == LON && data[(itmp + 1)] == '\0') {
- LYstopTargetEmphasis();
- TargetEmphasisON = FALSE;
- } else {
-@@ -979,7 +979,7 @@
- * last character of hightext if we are making
- * the link current. -FM
- */
-- if (flag == ON && data[(itmp + 1)] == '\0') {
-+ if (flag == LON && data[(itmp + 1)] == '\0') {
- LYstopTargetEmphasis();
- TargetEmphasisON = FALSE;
- } else {
-@@ -1025,7 +1025,7 @@
- s = s_curedit;
- #endif
-
-- if (flag != ON) {
-+ if (flag != LON) {
- int x;
-
- /*
-@@ -1119,13 +1119,13 @@
- NONNULL(target)));
-
- #if defined(TEXTFIELDS_MAY_NEED_ACTIVATION) && defined(INACTIVE_INPUT_STYLE_VH)
-- if (flag == OFF)
-+ if (flag == LOFF)
- textinput_redrawn = FALSE;
- #endif
-
- if (nlinks > 0) {
- #ifdef USE_COLOR_STYLE
-- if (flag == ON || links[cur].type == WWW_FORM_LINK_TYPE) {
-+ if (flag == LON || links[cur].type == WWW_FORM_LINK_TYPE) {
- LYmove(LYP + title_adjust, LXP);
- LynxChangeStyle(find_cached_style(cur, flag), STACK_ON);
- }
-@@ -1134,7 +1134,7 @@
- || LYGetHiliteStr(cur, 0) == NULL) {
- LYMoveToLink(cur, target, NULL,
- flag, links[cur].inUnderline, utf_flag);
-- lynx_start_link_color(flag == ON, links[cur].inUnderline);
-+ lynx_start_link_color(flag == LON, links[cur].inUnderline);
- } else {
- LYMoveToLink(cur, target, LYGetHiliteStr(cur, 0),
- flag, links[cur].inUnderline, utf_flag);
-@@ -1162,7 +1162,7 @@
- LYaddch('_');
-
- #ifdef USE_COLOR_STYLE
-- } else if (flag == OFF) {
-+ } else if (flag == LOFF) {
- hl2_drawn = TRUE;
- redraw_lines_of_link(cur);
- CTRACE2(TRACE_STYLE,
-@@ -1196,17 +1196,17 @@
- int row = LYP + hi_count + title_adjust;
-
- hi_offset = LYGetHilitePos(cur, hi_count);
-- lynx_stop_link_color(flag == ON, links[cur].inUnderline);
-+ lynx_stop_link_color(flag == LON, links[cur].inUnderline);
- LYmove(row, hi_offset);
-
- #ifdef USE_COLOR_STYLE
- CTRACE2(TRACE_STYLE,
- (tfp, "STYLE.highlight.line2: @(%d,%d), style=%d.\n",
- row, hi_offset,
-- flag == ON ? s_alink : s_a));
-- LynxChangeStyle(flag == ON ? s_alink : s_a, ABS_ON);
-+ flag == LON ? s_alink : s_a));
-+ LynxChangeStyle(flag == LON ? s_alink : s_a, ABS_ON);
- #else
-- lynx_start_link_color(flag == ON, links[cur].inUnderline);
-+ lynx_start_link_color(flag == LON, links[cur].inUnderline);
- #endif
-
- for (i = 0; (tmp[0] = hi_string[i]) != '\0'
-@@ -1225,7 +1225,7 @@
- }
- }
- }
-- lynx_stop_link_color(flag == ON, links[cur].inUnderline);
-+ lynx_stop_link_color(flag == LON, links[cur].inUnderline);
- }
- #ifdef SHOW_WHEREIS_TARGETS
- for (hi_count = target1_drawn ? 1 : 0;
---- a/src/LYUtils.h
-+++ b/src/LYUtils.h
-@@ -522,8 +522,8 @@
- /*
- * Miscellaneous.
- */
--#define ON 1
--#define OFF 0
-+#define LON 1
-+#define LOFF 0
- #define STREQ(a,b) (strcmp(a,b) == 0)
- #define STRNEQ(a,b,c) (StrNCmp(a,b,c) == 0)
-
diff --git a/www-client/lynx/lynx-2.8.8_pre10.ebuild b/www-client/lynx/lynx-2.8.8_pre10.ebuild
deleted file mode 100644
index aca3e35f069c..000000000000
--- a/www-client/lynx/lynx-2.8.8_pre10.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.8_pre10.ebuild,v 1.1 2012/02/13 20:38:54 radhermit Exp $
-
-EAPI=4
-
-inherit eutils versionator
-
-# VERSIONING SCHEME TRANSLATION
-# Upstream : Gentoo
-# rel. : _p
-# pre. : _rc
-# dev. : _pre
-
-case ${PV} in
- *_pre*) MY_P="${PN}${PV/_pre/dev.}" ;;
- *_rc*) MY_P="${PN}${PV/_rc/pre.}" ;;
- *_p*|*) MY_P="${PN}${PV/_p/rel.}" ;;
-esac
-
-DESCRIPTION="An excellent console-based web browser with ssl support"
-HOMEPAGE="http://lynx.isc.org/"
-SRC_URI="http://lynx.isc.org/current/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bzip2 cjk gnutls idn ipv6 nls ssl unicode"
-
-RDEPEND="sys-libs/ncurses[unicode?]
- sys-libs/zlib
- nls? ( virtual/libintl )
- ssl? (
- !gnutls? ( >=dev-libs/openssl-0.9.8 )
- gnutls? ( >=net-libs/gnutls-2.6.4 )
- )
- bzip2? ( app-arch/bzip2 )
- idn? ( net-dns/libidn )"
-
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- >=dev-util/pkgconfig-0.23"
-
-S="${WORKDIR}/${PN}$(replace_all_version_separators - $(get_version_component_range 1-3))"
-
-pkg_setup() {
- ! use ssl && elog "SSL support disabled; you will not be able to access secure websites."
-}
-
-src_prepare() {
- # fix up toplevel makefile to enable parallel make (bug #262972)
- #
- # add '+' prefix to lines using $(MAKE_RECUR),
- # making sure '+' comes after leading whitespace
- sed -i -e '/$(MAKE_RECUR)/ s/\([[:blank:]]\)/\1+/' makefile.in || \
- die "failed to update makefile.in"
-
- # fix configure for openssl compiled with kerberos (bug #267749)
- epatch "${FILESDIR}/lynx-2.8.7-configure-openssl.patch"
- epatch "${FILESDIR}"/${PN}-2.8.6-mint.patch
-}
-
-src_configure() {
- local myargs
-
- if use ssl ; then
- # --with-gnutls and --with-ssl are alternatives,
- # the latter enabling openssl support so it should be
- # _not_ be used if gnutls ssl implementation is desired
- if use gnutls ; then
- myargs+=" --with-gnutls" # ssl implementation = gnutls
- else
- myargs+=" --with-ssl" # ssl implementation = openssl
- fi
- fi
-
- use unicode && myargs+=" --with-screen=ncursesw"
-
- econf \
- --enable-nested-tables \
- --enable-cgi-links \
- --enable-persistent-cookies \
- --enable-prettysrc \
- --enable-nsl-fork \
- --enable-file-upload \
- --enable-read-eta \
- --enable-color-style \
- --enable-scrollbar \
- --enable-included-msgs \
- --enable-externs \
- --with-zlib \
- $(use_enable nls) \
- $(use_enable idn idna) \
- $(use_enable ipv6) \
- $(use_enable cjk) \
- $(use_enable unicode japanese-utf8) \
- $(use_with bzip2 bzlib) \
- $myargs
-}
-
-src_install() {
- emake install DESTDIR="${D}"
-
- sed -i -e "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help_main.html|" \
- "${ED}"/etc/lynx.cfg || die "lynx.cfg not found"
- if use unicode ; then
- sed -i -e '/^#CHARACTER_SET:/ c\CHARACTER_SET:utf-8' \
- "${ED}"/etc/lynx.cfg || die "lynx.cfg not found"
- fi
- dodoc CHANGES COPYHEADER PROBLEMS README
- docinto docs
- dodoc docs/*
- docinto lynx_help
- dodoc lynx_help/*.txt
- dohtml -r lynx_help/*
-}
diff --git a/www-client/lynx/lynx-2.8.8_pre5.ebuild b/www-client/lynx/lynx-2.8.8_pre5.ebuild
deleted file mode 100644
index 9052989e4b6d..000000000000
--- a/www-client/lynx/lynx-2.8.8_pre5.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.8_pre5.ebuild,v 1.4 2011/03/15 05:54:49 wormo Exp $
-
-EAPI=3
-
-inherit eutils versionator
-
-# VERSIONING SCHEME TRANSLATION
-# Upstream : Gentoo
-# rel. : _p
-# pre. : _rc
-# dev. : _pre
-
-case ${PV} in
- *_pre*) MY_P="${PN}${PV/_pre/dev.}" ;;
- *_rc*) MY_P="${PN}${PV/_rc/pre.}" ;;
- *_p*|*) MY_P="${PN}${PV/_p/rel.}" ;;
-esac
-
-DESCRIPTION="An excellent console-based web browser with ssl support"
-HOMEPAGE="http://lynx.isc.org/"
-SRC_URI="http://lynx.isc.org/current/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bzip2 cjk gnutls idn ipv6 nls ssl unicode"
-
-RDEPEND="sys-libs/ncurses[unicode?]
- sys-libs/zlib
- nls? ( virtual/libintl )
- ssl? (
- !gnutls? ( >=dev-libs/openssl-0.9.8 )
- gnutls? ( >=net-libs/gnutls-2.6.4 )
- )
- bzip2? ( app-arch/bzip2 )
- idn? ( net-dns/libidn )"
-
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- >=dev-util/pkgconfig-0.23"
-
-S="${WORKDIR}/${PN}$(replace_all_version_separators - $(get_version_component_range 1-3))"
-
-pkg_setup() {
- if ! use ssl
- then
- elog "SSL support disabled; you will not be able to access secure websites."
- fi
-}
-
-src_prepare() {
- # fix up toplevel makefile to enable parallel make (bug #262972)
- #
- # add '+' prefix to lines using $(MAKE_RECUR),
- # making sure '+' comes after leading whitespace
- sed -i -e '/$(MAKE_RECUR)/ s/\([[:blank:]]\)/\1+/' makefile.in || \
- die "failed to update makefile.in"
-
- # fix configure for openssl compiled with kerberos (bug #267749)
- epatch "${FILESDIR}/lynx-2.8.7-configure-openssl.patch"
- epatch "${FILESDIR}"/${PN}-2.8.6-mint.patch
-}
-
-src_configure() {
- local myargs
-
- if use ssl
- then
- # --with-gnutls and --with-ssl are alternatives,
- # the latter enabling openssl support so it should be
- # _not_ be used if gnutls ssl implementation is desired
- if use gnutls
- then
- myargs="$myargs --with-gnutls" # ssl implementation = gnutls
- else
- myargs="$myargs --with-ssl" # ssl implementation = openssl
- fi
- fi
-
- if use unicode
- then
- myargs="$myargs --with-screen=ncursesw"
- fi
-
- econf \
- --enable-nested-tables \
- --enable-cgi-links \
- --enable-persistent-cookies \
- --enable-prettysrc \
- --enable-nsl-fork \
- --enable-file-upload \
- --enable-read-eta \
- --enable-color-style \
- --enable-scrollbar \
- --enable-included-msgs \
- --enable-externs \
- --with-zlib \
- $(use_enable nls) \
- $(use_enable idn idna) \
- $(use_enable ipv6) \
- $(use_enable cjk) \
- $(use_enable unicode japanese-utf8) \
- $(use_with bzip2 bzlib) \
- $myargs
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
-
- sed -i -e "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help_main.html|" \
- "${ED}"/etc/lynx.cfg || die "lynx.cfg not found"
- if use unicode
- then
- sed -i -e '/^#CHARACTER_SET:/ c\CHARACTER_SET:utf-8' \
- "${ED}"/etc/lynx.cfg || die "lynx.cfg not found"
- fi
- dodoc CHANGES COPYHEADER PROBLEMS README
- docinto docs
- dodoc docs/*
- docinto lynx_help
- dodoc lynx_help/*.txt
- dohtml -r lynx_help/*
-}
diff --git a/www-client/lynx/lynx-2.8.8_pre9.ebuild b/www-client/lynx/lynx-2.8.8_pre9.ebuild
deleted file mode 100644
index 791c2fd77b1f..000000000000
--- a/www-client/lynx/lynx-2.8.8_pre9.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.8_pre9.ebuild,v 1.2 2011/09/15 20:38:34 radhermit Exp $
-
-EAPI=4
-
-inherit eutils versionator
-
-# VERSIONING SCHEME TRANSLATION
-# Upstream : Gentoo
-# rel. : _p
-# pre. : _rc
-# dev. : _pre
-
-case ${PV} in
- *_pre*) MY_P="${PN}${PV/_pre/dev.}" ;;
- *_rc*) MY_P="${PN}${PV/_rc/pre.}" ;;
- *_p*|*) MY_P="${PN}${PV/_p/rel.}" ;;
-esac
-
-DESCRIPTION="An excellent console-based web browser with ssl support"
-HOMEPAGE="http://lynx.isc.org/"
-SRC_URI="http://lynx.isc.org/current/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bzip2 cjk gnutls idn ipv6 nls ssl unicode"
-
-RDEPEND="sys-libs/ncurses[unicode?]
- sys-libs/zlib
- nls? ( virtual/libintl )
- ssl? (
- !gnutls? ( >=dev-libs/openssl-0.9.8 )
- gnutls? ( >=net-libs/gnutls-2.6.4 )
- )
- bzip2? ( app-arch/bzip2 )
- idn? ( net-dns/libidn )"
-
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- >=dev-util/pkgconfig-0.23"
-
-S="${WORKDIR}/${PN}$(replace_all_version_separators - $(get_version_component_range 1-3))"
-
-pkg_setup() {
- ! use ssl && elog "SSL support disabled; you will not be able to access secure websites."
-}
-
-src_prepare() {
- # fix up toplevel makefile to enable parallel make (bug #262972)
- #
- # add '+' prefix to lines using $(MAKE_RECUR),
- # making sure '+' comes after leading whitespace
- sed -i -e '/$(MAKE_RECUR)/ s/\([[:blank:]]\)/\1+/' makefile.in || \
- die "failed to update makefile.in"
-
- # fix configure for openssl compiled with kerberos (bug #267749)
- epatch "${FILESDIR}/lynx-2.8.7-configure-openssl.patch"
- epatch "${FILESDIR}"/${PN}-2.8.6-mint.patch
- epatch "${FILESDIR}"/${P}-zlib.patch
-}
-
-src_configure() {
- local myargs
-
- if use ssl ; then
- # --with-gnutls and --with-ssl are alternatives,
- # the latter enabling openssl support so it should be
- # _not_ be used if gnutls ssl implementation is desired
- if use gnutls ; then
- myargs+=" --with-gnutls" # ssl implementation = gnutls
- else
- myargs+=" --with-ssl" # ssl implementation = openssl
- fi
- fi
-
- use unicode && myargs+=" --with-screen=ncursesw"
-
- econf \
- --enable-nested-tables \
- --enable-cgi-links \
- --enable-persistent-cookies \
- --enable-prettysrc \
- --enable-nsl-fork \
- --enable-file-upload \
- --enable-read-eta \
- --enable-color-style \
- --enable-scrollbar \
- --enable-included-msgs \
- --enable-externs \
- --with-zlib \
- $(use_enable nls) \
- $(use_enable idn idna) \
- $(use_enable ipv6) \
- $(use_enable cjk) \
- $(use_enable unicode japanese-utf8) \
- $(use_with bzip2 bzlib) \
- $myargs
-}
-
-src_install() {
- emake install DESTDIR="${D}"
-
- sed -i -e "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help_main.html|" \
- "${ED}"/etc/lynx.cfg || die "lynx.cfg not found"
- if use unicode ; then
- sed -i -e '/^#CHARACTER_SET:/ c\CHARACTER_SET:utf-8' \
- "${ED}"/etc/lynx.cfg || die "lynx.cfg not found"
- fi
- dodoc CHANGES COPYHEADER PROBLEMS README
- docinto docs
- dodoc docs/*
- docinto lynx_help
- dodoc lynx_help/*.txt
- dohtml -r lynx_help/*
-}