summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/google-talkplugin/google-talkplugin-9999.ebuild')
-rw-r--r--www-plugins/google-talkplugin/google-talkplugin-9999.ebuild21
1 files changed, 16 insertions, 5 deletions
diff --git a/www-plugins/google-talkplugin/google-talkplugin-9999.ebuild b/www-plugins/google-talkplugin/google-talkplugin-9999.ebuild
index e39d2d412ef6..7ffa32446615 100644
--- a/www-plugins/google-talkplugin/google-talkplugin-9999.ebuild
+++ b/www-plugins/google-talkplugin/google-talkplugin-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/google-talkplugin/google-talkplugin-9999.ebuild,v 1.16 2013/07/31 15:20:03 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/google-talkplugin/google-talkplugin-9999.ebuild,v 1.17 2013/09/04 14:44:34 ottxor Exp $
EAPI=5
@@ -29,7 +29,9 @@ SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
#GoogleTalkPlugin binary contains openssl and celt
LICENSE="Google-TOS openssl BSD system-libCg? ( NVIDIA-r1 )"
-RESTRICT="strip mirror"
+
+OBSOLETE="no"
+[[ $OBSOLETE = yes ]] && RESTRICT="fetch strip" || RESTRICT="strip mirror"
RDEPEND="|| ( media-sound/pulseaudio media-libs/alsa-lib )
dev-libs/glib:2
@@ -69,9 +71,18 @@ done
# nofetch means upstream bumped and thus needs version bump
pkg_nofetch() {
- einfo "This version is no longer available from Google."
- einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
- einfo "Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for ${PN} first!)."
+ if [[ ${OBSOLETE} = yes ]]; then
+ elog "This version is no longer available from Google and the license prevents mirroring."
+ elog "This ebuild is intended for users who already downloaded it previously and have problems"
+ elog "with ${PV}+. If you can get the distfile from e.g. another computer of yours, or search"
+ use amd64 && MY_PKG="${MY_PKG/i386/amd64}"
+ elog "it with google: http://www.google.com/search?q=intitle:%22index+of%22+${MY_PKG}"
+ elog "and copy the file ${MY_PKG} to ${DISTDIR}."
+ else
+ einfo "This version is no longer available from Google."
+ einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
+ einfo "Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for ${PN} first!)."
+ fi
}
src_unpack() {