summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/cherokee')
-rw-r--r--www-servers/cherokee/ChangeLog7
-rw-r--r--www-servers/cherokee/cherokee-0.5.6.ebuild18
2 files changed, 13 insertions, 12 deletions
diff --git a/www-servers/cherokee/ChangeLog b/www-servers/cherokee/ChangeLog
index 81420295fb5e..8cd48a59e752 100644
--- a/www-servers/cherokee/ChangeLog
+++ b/www-servers/cherokee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/cherokee
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/ChangeLog,v 1.31 2006/12/27 02:37:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/ChangeLog,v 1.32 2006/12/27 04:48:46 flameeyes Exp $
+
+ 27 Dec 2006; Diego Pettenò <flameeyes@gentoo.org> cherokee-0.5.6.ebuild:
+ Run elibtoolize to apply Gentoo patches as needed; install the default
+ index.html page only if coverpage useflag is enabled (not by default) to
+ avoid the nasty $ROOT lookup.
*cherokee-0.5.6 (27 Dec 2006)
diff --git a/www-servers/cherokee/cherokee-0.5.6.ebuild b/www-servers/cherokee/cherokee-0.5.6.ebuild
index dd5f86d947f2..4e4788675a6e 100644
--- a/www-servers/cherokee/cherokee-0.5.6.ebuild
+++ b/www-servers/cherokee/cherokee-0.5.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/cherokee-0.5.6.ebuild,v 1.1 2006/12/27 02:37:08 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/cherokee-0.5.6.ebuild,v 1.2 2006/12/27 04:48:46 flameeyes Exp $
-inherit eutils pam versionator
+inherit eutils pam versionator libtool
DESCRIPTION="An extremely fast and tiny web server."
SRC_URI="http://www.cherokee-project.com/download/$(get_version_component_range 1-2)/${PV}/${P}.tar.gz"
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.cherokee-project.com/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="ipv6 ssl gnutls static pam"
+IUSE="ipv6 ssl gnutls static pam coverpage"
RDEPEND=">=sys-libs/zlib-1.1.4-r1
gnutls? ( net-libs/gnutls )
@@ -21,6 +21,8 @@ RDEPEND=">=sys-libs/zlib-1.1.4-r1
src_unpack() {
unpack ${A}
+ elibtoolize
+
# use cherokee user/group
sed -i -e 's|^#\(User \).*$|\1cherokee|' \
-e 's|^#\(Group \).*$|\1cherokee|' "${S}/cherokee.conf.sample.pre" || \
@@ -74,15 +76,9 @@ src_install () {
newpamd pam.d_cherokee ${PN} || die "newpamd failed"
newinitd "${FILESDIR}/${PN}-initd-0.5.6" ${PN} || die "newinitd failed"
- keepdir /etc/cherokee/mods-enabled /etc/cherokee/sites-enabled
+ keepdir /etc/cherokee/mods-enabled /etc/cherokee/sites-enabled /var/www/localhost/htdocs
- # be nice and don't overwrite a user's pre-existing index.html
- # (unless they're the same).
- if [[ -f "${ROOT}"/var/www/localhost/htdocs/index.html ]] ; then
- diff "${ROOT}"/var/www/localhost/htdocs/index.html \
- "${D}"/var/www/localhost/htdocs/index.html &>/dev/null || \
- mv "${D}"/var/www/localhost/htdocs/{,cherokee-}index.html
- fi
+ use coverpage || rm -f "${D}"/var/www/localhost/htdocs/index.html
}
pkg_postinst() {