summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/wbar/wbar-2.3.4.ebuild')
-rw-r--r--x11-misc/wbar/wbar-2.3.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/wbar/wbar-2.3.4.ebuild b/x11-misc/wbar/wbar-2.3.4.ebuild
new file mode 100644
index 000000000000..f9b02aa66ad4
--- /dev/null
+++ b/x11-misc/wbar/wbar-2.3.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/wbar-2.3.4.ebuild,v 1.1 2012/09/24 20:33:42 hasufell Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="A fast, lightweight quick launch bar"
+HOMEPAGE="http://code.google.com/p/wbar/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+RDEPEND="media-libs/imlib2[X]
+ virtual/init
+ x11-libs/libX11
+ gtk? ( gnome-base/libglade
+ media-libs/freetype:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ use gtk || epatch "${FILESDIR}"/${PN}-2.3.3-cfg.patch
+ epatch "${FILESDIR}"/${PN}-2.3.3-{desktopfile,nowerror,test}.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable gtk wbar-config)
+}