summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xmobar/xmobar-0.9.2-r1.ebuild')
-rw-r--r--x11-misc/xmobar/xmobar-0.9.2-r1.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/x11-misc/xmobar/xmobar-0.9.2-r1.ebuild b/x11-misc/xmobar/xmobar-0.9.2-r1.ebuild
deleted file mode 100644
index c9830d15a7ad..000000000000
--- a/x11-misc/xmobar/xmobar-0.9.2-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmobar/xmobar-0.9.2-r1.ebuild,v 1.5 2010/06/16 22:30:17 kolmodin Exp $
-
-CABAL_FEATURES="bin"
-inherit base haskell-cabal
-
-DESCRIPTION="A Minimalistic Text Based Status Bar"
-HOMEPAGE="http://code.haskell.org/~arossato/xmobar"
-SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 -sparc ~x86"
-IUSE="xft unicode mail"
-
-RDEPEND=">=dev-lang/ghc-6.6.1
- dev-haskell/mtl
- dev-haskell/parsec
- dev-haskell/stm
- unicode? ( dev-haskell/utf8-string )
- xft? ( dev-haskell/utf8-string
- dev-haskell/x11-xft )
- mail? ( dev-haskell/hinotify )"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6"
-
-PATCHES=("${FILESDIR}/${P}-cpu-high-load.patch")
-
-src_compile() {
- CABAL_CONFIGURE_FLAGS="--constraint=base<4"
-
- if use xft; then
- CABAL_CONFIGURE_FLAGS="$CABAL_CONFIGURE_FLAGS --flags=with_xft"
- else
- CABAL_CONFIGURE_FLAGS="$CABAL_CONFIGURE_FLAGS --flags=-with_xft"
- fi
-
- if use unicode; then
- CABAL_CONFIGURE_FLAGS="$CABAL_CONFIGURE_FLAGS --flags=with_utf8"
- else
- CABAL_CONFIGURE_FLAGS="$CABAL_CONFIGURE_FLAGS --flags=-with_utf8"
- fi
-
- if use mail; then
- CABAL_CONFIGURE_FLAGS="$CABAL_CONFIGURE_FLAGS --flags=with_inotify"
- else
- CABAL_CONFIGURE_FLAGS="$CABAL_CONFIGURE_FLAGS --flags=-with_inotify"
- fi
-
- cabal_src_compile
-}
-
-src_install() {
- cabal_src_install
-
- dodoc xmobar.config-sample README
-}