summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gaim-otr/gaim-otr-1.0.2.ebuild')
-rw-r--r--x11-plugins/gaim-otr/gaim-otr-1.0.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-plugins/gaim-otr/gaim-otr-1.0.2.ebuild b/x11-plugins/gaim-otr/gaim-otr-1.0.2.ebuild
new file mode 100644
index 000000000000..bc44e5ee3bff
--- /dev/null
+++ b/x11-plugins/gaim-otr/gaim-otr-1.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-otr/gaim-otr-1.0.2.ebuild,v 1.1 2005/01/17 21:24:40 rizzo Exp $
+
+inherit flag-o-matic eutils debug
+
+DESCRIPTION="(OTR) Messaging allows you to have private conversations over instant messaging"
+HOMEPAGE="http://www.cypherpunks.ca/otr/"
+SRC_URI="http://www.cypherpunks.ca/otr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=net-im/gaim-1.0.1
+ dev-libs/libgpg-error
+ dev-libs/libgcrypt"
+
+src_compile() {
+ strip-flags
+ replace-flags -O? -O2
+
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "Install failed"
+ dodoc COPYING ChangeLog README
+}