summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/blueglass-xcursors/blueglass-xcursors-0.4.ebuild')
-rw-r--r--x11-themes/blueglass-xcursors/blueglass-xcursors-0.4.ebuild23
1 files changed, 6 insertions, 17 deletions
diff --git a/x11-themes/blueglass-xcursors/blueglass-xcursors-0.4.ebuild b/x11-themes/blueglass-xcursors/blueglass-xcursors-0.4.ebuild
index ca97518fd22f..bfc3c3410f8a 100644
--- a/x11-themes/blueglass-xcursors/blueglass-xcursors-0.4.ebuild
+++ b/x11-themes/blueglass-xcursors/blueglass-xcursors-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/blueglass-xcursors/blueglass-xcursors-0.4.ebuild,v 1.20 2006/01/03 20:40:17 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/blueglass-xcursors/blueglass-xcursors-0.4.ebuild,v 1.21 2006/01/03 21:12:45 nelchael Exp $
MY_P="5532-BlueGlass-XCursors-3D-${PV}"
DESCRIPTION="A high quality set of Xfree 4.3.0 animated mouse cursors"
@@ -12,29 +12,18 @@ SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 mips ppc ppc64 sparc x86"
IUSE=""
-DEPEND=""
-RDEPEND="|| ( x11-base/xorg-server virtual/x11 )"
+RDEPEND=""
+DEPEND="${RDEPEND}"
# Note: although the package name is BlueGlass, the tarball & authors directions
# use the directory 'Blue'.
src_install() {
- # Set up X11 implementation
- X11_IMPLEM_P="$(best_version virtual/x11)"
- X11_IMPLEM="${X11_IMPLEM_P%-[0-9]*}"
- X11_IMPLEM="${X11_IMPLEM##*\/}"
- einfo "X11 implementation is ${X11_IMPLEM}."
-
- dodir /usr/share/cursors/${X11_IMPLEM}/Blue/cursors/
- cp -R ${WORKDIR}/${MY_P:5}/Blue/cursors ${D}/usr/share/cursors/${X11_IMPLEM}/Blue/ || die
+ dodir /usr/share/cursors/xorg-x11/Blue/cursors/
+ cp -R ${WORKDIR}/${MY_P:5}/Blue/cursors ${D}/usr/share/cursors/xorg-x11/Blue/ || die
dodoc ${WORKDIR}/${MY_P:5}/README
}
pkg_postinst() {
- # dirty hacks...
- X11_IMPLEM_P="$(best_version virtual/x11)"
- X11_IMPLEM="${X11_IMPLEM_P%-[0-9]*}"
- X11_IMPLEM="${X11_IMPLEM##*\/}"
-
einfo "To use this set of cursors, edit or create the file ~/.Xdefaults"
einfo "and add the following line:"
einfo "Xcursor.theme: Blue"
@@ -43,7 +32,7 @@ pkg_postinst() {
einfo "Xcursor.size: 48"
einfo ""
einfo "To globally use this set of mouse cursors edit the file:"
- einfo " /usr/local/share/cursors/${X11_IMPLEM}/default/index.theme"
+ einfo " /usr/share/cursors/xorg-x11/default/index.theme"
einfo "and change the line:"
einfo " Inherits=[current setting]"
einfo "to"